0

I am using the model builder in ArcMap to create zonal statistics as table (daily time series-so iterating rasters in the beginning). The tool works fine, it's just that I have another additional step, where I want the zonal statistics table to be sorted in descending order (for the polygon IDs) rather than the default ascending order. So, for that I added the sort tool in the model, the tool is then linked to the append tool to finally merge all the zonal tables into a single table. In all this I am getting an error in the append tool which states that all the inputs need to be in the same format. Although, in the sort tool I am setting the sort output as table and target dataset in Append tool is also a .dbf table.

How to fix this in ArcMap 10.7.1? enter image description here enter image description here

4
  • 2
    The append tool requires all tables to have the same schema. Do all tables have the same fields? Otherwise, perhaps the merge tool would be more suitable. It combines tables into a single new table, rather than append tables to an existing table.
    – Fezter
    Nov 10, 2020 at 22:23
  • Yes, they have same the fields. The reason I am not using the merge tool is that it creates new columns for each dataset(day), but I want the fields/columns as ID, Mean and Date. It think in case of Merge it would be ID, Mean, day1, day2...dayN Nov 10, 2020 at 22:31
  • 2
    Does ArcMap report an error number?
    – Fezter
    Nov 10, 2020 at 23:06
  • Yes. it's 00038 Nov 10, 2020 at 23:33

1 Answer 1

1

I don't know if your error is related to this issue but your model logic is flawed. The append tool takes a LIST of datasets as input, your model is feeding one at a time on each loop of the iterator. Not only is this wrong but highly inefficient. You need to feed the output of sort into a collects value tool, expose that as a parameter and then make that a sub-model in a master model with a single append tool. There are many Q&A on this forum where people are making the same mistake. An answer to this question provides a link to a you tube video, or you could just look at the help file and understand sub-modelling and when to use the collect tool. Be aware don't make the error of simply linking to the collects value tool, that part must be a model embedded in a master model.

I don't know if that solves your error but at least you will be doing it right!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.