6

I just newly installed QGIS 3.16 because I got a new Laptop:

Lenovo ThinkPad T490s
i5-8265
8 GB RAM
256 GB SSD)

But when I try to use the program, it always goes into the "not responding" mode. It happens when I click on whatever part of QGIS (whether it be the task bar, starting a new project or the browser window), it even happens when I try to enlarge the window.

I already tried it with reinstalling, restarting the computer and installing the 3.10 version, but for days now nothing has changed.

Because I have to wait for about a minute after every click/action I make, I'm practically unable to work with QGIS. Does anyone know how I can fix it?

7
  • Some troubleshooting tips (so not an answer): try disabling your plugins (either start QGIS with --noplugins argument on the command line, or manually disable all plugins in the plugin manager dialog and restart), open your task manager and see if anything is using lots of CPU or memory.
    – user2856
    Nov 15, 2020 at 6:03
  • 5
    And another thing to check: do you have many network drives mapped? If so, you can hide those drives that are irrelevant to GIS work, then QGIS responds better. This is done in the Browser tab, right click on the irrelevant drive and choose "Hide"
    – Micha
    Nov 15, 2020 at 9:06
  • 2
    Thank you. Yes the problem was the network drives. The problem actually only occurs when a network drive is disconnected. Either closing the browser tab or hiding the networks helped to fix it. In order to be able to do that first I had to connect to the networks so QGis would not become unresponsive.
    – Merle
    Nov 16, 2020 at 14:53
  • This is actually a really useful string of comments. Would someone of you care to turn this into an answer and maybe edit the question to relflect the relevant culprits?
    – thymaro
    Nov 27, 2020 at 10:38
  • 1
    For anyone who stumbles across this, for re-showing hidden paths and network drives: github.com/qgis/QGIS/issues/33164#issuecomment-708651902
    – thymaro
    Nov 30, 2020 at 6:18

1 Answer 1

16

I had the same "not responding" problem. As recommended, I closed the browser tab and now it seems to work.

Quoted from comments:

If you have many network drives mapped, you can hide those drives that are irrelevant to GIS work, then QGIS responds better. This is done in the Browser tab, right click on the irrelevant drive and choose "Hide"

Yes the problem was the network drives. The problem actually only occurs when a network drive is disconnected. Either closing the browser tab or hiding the networks helped to fix it. In order to be able to do that first I had to connect to the networks so QGIS would not become unresponsive.

Also check out this comment on QGIS Issues: https://github.com/qgis/QGIS/issues/33164#issuecomment-708651902

Connect to your VPN/Network drive → QGIS should start up without problems

in QGIS browser, right-click on the network drive and click "Hide from Browser" → QGIS will work as fast and without bugs as before, you can disconnect from VPN/network drive now

enter image description here

If you want to show the hidden drive in the Browser again, go to Settings -> Options -> Advanced -> Browser -> hidden Paths -> edit the line or right-click -> delete setting

enter image description here

otherwise drag-and-drop will workaround the browser problem completely

2
  • I've had this issue with QGIS being slow in Windows forever and got stuck in the rabbit hole of profiles and trying to clean temporary memory without avail. This worked like a charm. Thanks!
    – Rob
    Aug 18, 2022 at 13:58
  • Had the same issue with QGIS ver. 3.26.2 and 3.26.3. Both closing the "Browser Panel" or hiding all network drives did the trick. Thanks!
    – 9ls1
    Sep 30, 2022 at 9:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.