0

I tried to do a batch export of 19 geopackage layers to dxf and got an error I don't understand (I don't speak Python very well). First error of 19 pasted in below from my log, all of them the same.

Processing algorithm 1/19…
Algorithm v.out.dxf starting…
Input parameters:
{'GRASS_MIN_AREA_PARAMETER': 0.0001, 'GRASS_REGION_PARAMETER': None, 'GRASS_SNAP_TOLERANCE_PARAMETER': -1.0, 'input': '1_634370ab_e31a_4d68_91b9_bdbacd5dc470', 'output': 'H:/Data/Vector/map/layers/2.dxf'}

g.proj -c proj4="+proj=longlat +datum=NAD83 +no_defs"
v.in.ogr min_area=0.0001 snap=-1.0 input="H:\Data\Vector\map\layers\1.gpkg" layer="1" output="vector_5fb0b2ffecf5f2" --overwrite -o
g.region n=42.1083199772876 s=42.0816710148285 e=-74.4838672516787 w=-74.5197998630435
v.out.dxf input=vector_5fb0b2ffecf5f2 output="H:/Data/Vector/map/layers/2.dxf" --overwrite

Starting GRASS GIS...
Traceback (most recent call last): File "C:/PROGRA~1/QGIS3~1.14/apps/qgis/./python/plugins\processing\algs\grass7\Grass7Algorithm.py", line 434, in processAlgorithm Grass7Utils.executeGrass(self.commands, feedback, self.outputCommands)
File "C:/PROGRA~1/QGIS3~1.14/apps/qgis/./python/plugins\processing\algs\grass7\Grass7Utils.py", line 401, in executeGrass
feedback.reportError(line.strip())
TypeError: reportError() missing 1 required positional argument: 'fatalError'

Algorithm v.out.dxf failed…
Execution failed after 0.73 seconds

1

Two suggestions:

Can you try the following In the v.out.dxf dialog window pull down the "Advanced parameters", then in the "GRASS GIS 7 Region" click the ellipsis and select "Calculate from layer" and select your export layer. And then "Run".

Second suggestion:

Why would you go from a geopackage, inport to GRASS only to then export to DXF? Why not simply run a loop using ogr2ogr, directly from *.gpkg to *.dxf? Something like: (depending on your command shell)

for f in *.gpkg; do
dxf=`basename ${f} .gpkg`.dxf
ogr2ogr -f DXF ${dxf} ${f}
done

??

HTH

1
  • I didn't use ogr2ogr because I was using the GRASS toolbox inside QGIS. I ended up using the GDAL "convert format" tool and that worked fine. Thanks for the suggestions, I'll try the ogr2ogr next time =)
    – Brian
    Nov 15 '20 at 22:06
0

I didn't end up getting the GRASS tool to work within QGIS, but I used the GDAL "convert format" tool and that worked well enough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.