4

I am using QGIS 3.8 and installed python 3.9 where my Scipy is linked (I guess). The thing is my QGIS has a warning error that python that says:

Semi-Automatic Classification Plugin: Error. Check Python Scipy installation for 
the Semi-Automatic Classification Plugin

When I checked the python version in QGIS it says there that its 3.6. Is there a way to change the python version in QGIS so it recognizes the Pythn 3.9 where I guess I have my Scipy fixed. I'm using semi automatic plugin to process some images.

I am not a programmer so I don't know any of this I'm so sorry.

1
  • good question - ill do some digging, its probably an environment variable or similar that needs to be changed, OR it could simply be that you still have the older python mapped in your PATH system environment variable and QGIS recognizes this one. From my perspective, unless needed, I would remove any duplicate references in your PATH environment variable anyways.
    – nr_aus
    Nov 19, 2020 at 5:20

2 Answers 2

1

Ah ok ive found it. in addition to my comments above.....

in Options > System > Current Environment Variables - there are two

  • PYTHONHOME
  • PYTHONPATH

Check that these are correct.

references https://docs.qgis.org/3.16/en/docs/pyqgis_developer_cookbook/intro.html

4
  • I checked it and I guess it was okay but I'm still recceiving the same error.
    – Johnny
    Nov 19, 2020 at 13:12
  • I dont have pythonhome and pythonpath but I do have Path where in the link below is written as the value
    – Johnny
    Nov 19, 2020 at 13:13
  • /Library/Frameworks/GDAL.framework/Programs:/Library/Frameworks/Python.framework/Versions/3.8/bin:/usr/bin:/bin:/usr/sbin:/sbin
    – Johnny
    Nov 19, 2020 at 13:13
  • yep make sure you set pythonhome variable. Some doco links ive added in above for reference, but for you - set pythonhome.
    – nr_aus
    Nov 20, 2020 at 0:58
0

These are the some screenshots maybe it can help.

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.