I'm trying to iterate through a folder which contains many Lidar-Intensity Images as .jpg files.

I want to reclassify them all with the same thresholds (3 classes). I used the "Iterate Raster" and after that the "Reclassify" tool. But the result in the output folder doesn't create a single output raster.

I also tried to use "classify by table" without any success too. It also doesn't work if I try to use other tools like "select by mask" or the raster calculator. When I use these functions on the .jpg files manually (not in the ModelBuilder) it works without any problems.

Here is my model, has anyone suggestions?

enter image description here

  • you should add the software like "arcmap" as tag to your question, since qgis and arcmap/arcgis have a modelbuilder
    – eurojam
    Nov 19, 2020 at 19:10

1 Answer 1


You iterate raster will output something like "path\raster_name.jpg", meanwhile your raster classification need to save this raster into a Geodatabase. If you run the raster classification manually it will ask you a geodatabase to save the new raster.

So for this you have to add another process to convert your current path without the extension file ".jpg" otherwise the Geodatabase will not accept it.

1- Instert -> model only -> Parse Path

By using parse path you can get some attributes from your file. So you should make variable by parameter and as a parser type you should choose "Name". This will return the name of the image without extension. Than on the end of model you should use the value returned by the parse path not the name returned by iterate raster. Careful in you image name because geodatabase have several restriction of naming files inside it (they should not have special characters). enter image description here

  • 1
    Yes that worked! Thank you really much you saved me hours of work.
    – Radde1683
    Nov 20, 2020 at 12:59
  • I cant count how many times community saved me :D Good luck
    – riflo
    Nov 20, 2020 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.