0

So I need to create a cell grid with 1km2 for each cell. Since the default WGS84 uses degrees and not meters/kilometers for unit of measurement, I tried to change the projection for one that use meters (EPSG:5017 and others Portugal based ones), and changed de CRS of the layers to the same one. That made QGIS give this error message (Error: Fallback transform failed) every time I try to move around the map (though zooming in and out still works), and I still can't create a grid because when I try to use a layer for the grid extent or try to draw it, it gives WGS84 coordinates, while the "create grid" function interprets them as EPSG:5017 coordinates (image 1). Also, the thing at the bottom that shows the coordinates of the mouse still seem to be in WGS84, so I can't input the coordinates myself.

This is getting frustrating because every time I think I found a work-around, something doesn't work the way that it should (or that I though it should) or doesn't work at all. I don't think it's a problem with the projection system it self, but it might be because I only tried systems that start with "Lisbon", but I don't what other systems could work.

Image 1 enter image description here

2
  • so not use setCRS to "change" the CRS of a layer, it just changes the meta-data - use export->save as and specify a new CRS instead
    – Ian Turton
    Nov 24, 2020 at 20:12
  • Thanks, but it doesn't help. Update: I can create a grid, but it's supposed to have 1x1 meter cells but it creates a 6x3 grid that is able to completely cover Portugal, so it's clearly still creating the grid based on degrees and not meters, despite having meters as the unit in the function window. Nov 25, 2020 at 0:16

1 Answer 1

1

Try using EPSG:3763, as QGis seems not to be able to transform lat/lon to EPSG:5017 (at least it gives me an error about south orientated systems).

enter image description here

You will then be able to specify your grid size and extent in metres.

2
  • Thank you for the response, but the problem remains the same. It's like QGIS is just pretending to accept the CRS changs, but it's still running WGS84 underneath. Nov 25, 2020 at 11:16
  • Just to be sure, I saved the layers with the new CRS, and changed layers by saving the new layer with the correct coordinate system, and changed the project CRS in Project properties - CRS. Is there anywhere else where I would need to change something? What I find weird is that in the CRS layer selector, it keeps telling me that "This layer doesn't seem to have a specified projection"; and it tells me that by default it's the same as the project's. Nov 25, 2020 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.