3

When using the export function via Project -> Import/Export my labels do not appear in CAD afterwards. I checked the "Export as MTEXT" box and tried using different scales. But I cannot get the labels to be exported to the dxf-file. The polygons and lines are being exported just fine. Only the labels are missing.

I'm working with QGIS 3.10.4 and open my dxf-files with AutoCAD LT 2019.

Anyone an idea what might be wrong or how I can get my labels to CAD?

3 Answers 3

3

I found the solution myself:

In the layer properties the size of the labels mustn't be in "Meters at Scale". I can't get it to work, no matter what settings I use.

It works fine with "Map Units", no matter the scale you choose in the export window.

When using "Millimeters", "Points", "Pixels" or "Inches" you have to set the Symboloby scale in the export window to the exact scale you are currently viewing in your map. E.g. if you're currently on a scale of 1:4105 in your map view, you'll have to set exactly this scale in the export window for the labels to be exported.

1

Important is the Export labels as MTEXT elements. It will impact your edits in AutoCAD when the Select Similar option is selected. With MTEXT - you cannot apply the defined font style to your items! So if you wish to change the font style (other than .shx -shaped) then it's good to export your layer without MTEXT. On the other hand, by exporting with MTEXT you will be able to set the font background and label. enter image description here

It's good to know the further font circumstances generated by these 2 ways of DXF export.

0

The Scale factor for Symbology needs to be set:

1:1,000 works for this example.

enter image description here

1
  • Unfortunately your approached didn't work for me, but it got me to try something different out and the worked. So thanks! :)
    – Sachikoda
    Dec 1, 2020 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.