1

I've managed to break the ability to use Notebooks in ArcGIS Pro by installing the deep learning modules in a cloned environment.

These are the dependencies:

conda install -c esri -c fastai -c pytorch arcgis=1.8.2 scikit-image=0.15.0 pillow=6.2.2 libtiff=4.0.10 fastai=1.0.60 pytorch=1.4.0 torchvision=0.5.0 --no-pin

The cloned environment works fine in an IDE, but notebooks refuse to open in Pro. I'm assuming one of the dependencies is the problem, is there a way to re-activate notebooks in Pro?

3
  • Is the option to notebook greyed out, or the notebook refuses to open when clicked on it? Also, are the notebooks working fine outside the cloned env? Nov 29 '20 at 14:27
  • It tries to open then fails. However, no, all notebooks were broken and I've just had to freshly install Pro. Notebooks are now working in Pro under the base env. Bringing up the question, why would a clone env break all notebooks for Pro? I'd rather not have to re-install Pro if the issue comes again. So I'm still looking for a resolution if others have had a similar problem.
    – Stew
    Nov 29 '20 at 14:54
  • It's possible one of the modules that you're installing upgrades or modifies another module that the Notebooks require. That either breaks it, or Pro is looking for a certain reference that doesn't exist any more. If you can reproduce it with 4 steps (clone enviro, add modules, activate, notebooks fail to open), I'd submit it to Tech Support. Keep in mind, you should be able to switch back to the base Pro conda environment to get it working again. You can't add/modify that environment.
    – KHibma
    Nov 30 '20 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.