2

I have set up a basic geo package example with the schema extension, specifically for data constraints and enums. When I bring this into QGIS v3.16, I cannot see my extension work implemented anywhere (i.e. enum pick-list not showing when I add a new feature).

Is this possible at all in QGIS yet? Or do I just need to set up a "Value Map" widget in the Attributes Form properties window for now?

1
  • keen on hearing about how you go with this. I'm going to be stuck with this problem soon, am about to implement geopackage related tables extension and am wondering how im going to deal with it within QGIS. – nr_aus Dec 14 '20 at 8:12
1

QGIS is using GDAL for GeoPackages and by the GDAL documentation in https://gdal.org/drivers/vector/gpkg.html#level-of-support-of-geopackage-extensions the schema extension is not supported. Related tables extension is not even mentioned in the documentation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.