0

I am having trouble with the following: For a project I need a topographic map with contour lines of a specific area. I've googled around and the only suitable option (without buying expensive software subscriptions) I could find was using QGIS. I am running Version 3.16.1 Hannover.

I followed this tutorial: https://youtu.be/aJm9lewzooU?t=274 (Time Stamp 4:34)

I created a raster using the path option in Google Earth Pro and then added elevation data from http://gpsvisualizer.com/elevation, downloaded that as a CSV and imported it through Add Layer > Add Delimited Text Layer. No problems until here.

But when I try to run the natural neighbour tool I always get the same error, no matter what I do:

QGIS version: 3.16.1-Hannover QGIS code revision: 3ecbe06f78 Qt version: 5.14.2 GDAL version: 3.1.2 GEOS version: 3.8.1-CAPI-1.13.3 PROJ version: Rel. 6.3.2, May 1st, 2020 
  SAGA version 7.3.0 is not officially supported - algorithms may encounter issues

Processing algorithm…
Algorithm 'Natural neighbour' starting… 
  Input parameters: { 'FIELD' : 'altitude (m)', 'METHOD' : 1, 'SHAPES' : 'delimitedtext://file:///Users/nico/Desktop/PDC/qgis%20test/contour.txt?type=csv&delimiter=%5Ct&maxFields=10000&detectTypes=yes&xField=longitude&yField=latitude&crs=EPSG:4326&spatialIndex=no&subsetIndex=no&watchFile=no', 'TARGET_OUT_GRID' : 'TEMPORARY_OUTPUT', 'TARGET_TEMPLATE' : None, 'TARGET_USER_FITS' : 0, 'TARGET_USER_SIZE' : 0.0005, 'TARGET_USER_XMIN TARGET_USER_XMAX TARGET_USER_YMIN TARGET_USER_YMAX' : '-8.454885447,-8.451031086,41.837634791,41.839088587 [EPSG:4326]', 'WEIGHT' : 0 }

grid_gridding "Natural Neighbour" -TARGET_DEFINITION 0 -SHAPES "/private/var/folders/0v/y9l9kz9d4jsd8brqmj4z4_mr0000gn/T/processing_zaDUCh/35053aaf34db4508b33b526507c834a0/SHAPES.shp"
-FIELD "altitude (m)" -METHOD 1 -TARGET_USER_XMIN -8.454885447 -TARGET_USER_XMAX -8.451031086 -TARGET_USER_YMIN 41.837634791 -TARGET_USER_YMAX 41.839088587 -TARGET_USER_SIZE 0.0005 -TARGET_USER_FITS 0 -WEIGHT 0.0 -TARGET_OUT_GRID "/private/var/folders/0v/y9l9kz9d4jsd8brqmj4z4_mr0000gn/T/processing_zaDUCh/c71189e2b98047a680f774f0920ce824/TARGET_OUT_GRID.sdat"
____________________________

SAGA Version: 7.3.0

Unknown option 'SHAPES'
library path: /Applications/QGIS.app/Contents/MacOS/lib/saga/ library name: libgrid_gridding library : grid_gridding tool : Natural Neighbour identifier : 3 author : O.Conrad (c) 2008
____________________________

Usage: saga_cmd grid_gridding 3 [-POINTS <str>] [-FIELD <str>] [-TARGET_DEFINITION <str>] [-TARGET_USER_SIZE <double>] [-TARGET_USER_XMIN <double>] [-TARGET_USER_XMAX <double>] [-TARGET_USER_YMIN <double>] [-TARGET_USER_YMAX <double>] [-TARGET_USER_COLS <num>] [-TARGET_USER_ROWS <num>] [-TARGET_USER_FITS <str>] [-TARGET_TEMPLATE <str>] [-TARGET_OUT_GRID <str>] [-METHOD <str>] [-WEIGHT <double>]  
-POINTS:<str> Points Shapes (input)  
-FIELD:<str> Attribute Table field  
-TARGET_DEFINITION:<str> Target Grid System Choice Available Choices: [0] user defined [1] grid or grid system Default: 0  
-TARGET_USER_SIZE:<double> Cellsize Floating point Minimum: 0.000000 Default: 1.000000  
-TARGET_USER_XMIN:<double> West Floating point Default: 0.000000
-TARGET_USER_XMAX:<double> East Floating point Default: 100.000000
-TARGET_USER_YMIN:<double> South Floating point Default: 0.000000
-TARGET_USER_YMAX:<double> North Floating point Default: 100.000000
-TARGET_USER_COLS:<num> Columns Integer Minimum: 1 Default: 100
-TARGET_USER_ROWS:<num> Rows Integer Minimum: 1 Default: 100
-TARGET_USER_FITS:<str> Fit Choice Available Choices: [0] nodes [1] cells Default: 0
-TARGET_TEMPLATE:<str> Target System Grid (optional input)
-TARGET_OUT_GRID:<str> Target Grid Grid (output)
-METHOD:<str> Method Choice Available Choices: [0] Linear [1] Sibson [2] Non-Sibsonian Default: 1
-WEIGHT:<double> Minimum Weight Floating point Maximum: 0.000000 Default: 0.000000

Execution completed in 2.83 seconds
Results: {'TARGET_OUT_GRID': '/private/var/folders/0v/y9l9kz9d4jsd8brqmj4z4_mr0000gn/T/processing_zaDUCh/c71189e2b98047a680f774f0920ce824/TARGET_OUT_GRID.sdat'}

Loading resulting layers The following layers were not correctly generated. 
• private/var/folders/0v/y9l9kz9d4jsd8brqmj4z4_mr0000gn/T/processing_zaDUCh/c71189e2b98047a680f774f0920ce824/TARGET_OUT_GRID.sdat 
• private/var/folders/0v/y9l9kz9d4jsd8brqmj4z4_mr0000gn/T/processing_zaDUCh/e3641d348d054473815617c8c049c41b/TARGET_OUT_GRID.sdat 
You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm.

I've tried to change every single parameter in the natural neighbour tool, formatted the CSV to only three columns (lat/long/alt), created a shp file copy and deleted the original layer, to no avail. I always get the same error.

I am running it on a MacBook Pro Retina Early 2015 with MacOS Big Sur (11.1) installed.

I've added screenshots of the parameters and the csv file I used.

I really hope someone can help me. If not is there another way to create topographic maps from Google Earth?

Version Info: Version

CSV table: CSV table

After adding the CSV: After adding the CSV

Parameters used in natural neighbour: Parameters used in natural neighbour

4
  • Is there a specific reason why you want to get elevation data by such a complicated detour? You could simply download freely available digital elevation models (like SRTM) - have a look at opendem.info or srtm.csi.cgiar.org or asterweb.jpl.nasa.gov/gdem.asp – Babel Dec 19 '20 at 22:30
  • Where do you have the commas from in your data? Try replacing the commas with points in the file you download from gpsvisualizer.com. Does that help? If not, provide more information: Unfortunately, you don't write anything about what the output is when you run Natural Neighbour: an empty raster layer? None? Did you note the yellow warning message on your screenshot? Can you share your CSV? – Babel Dec 19 '20 at 22:39
  • Ready made contour lines for northern Portugal, direct link (copy the whole text until the end: 73781 and paste it manually to your browser and download the zip-archives at the bottom): opendem.info/opendem_client/opendem.jsp?bounds=-1051773.5090576 5065634.73781,-787607.13934078 5065634.73781,-787607.13934078 5146352.2396679,-1051773.5090576 5146352.2396679,-1051773.5090576 5065634.73781 – Babel Dec 19 '20 at 22:46
  • Not sure, but this post may help. – Kadir Şahbaz Dec 19 '20 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.