I am fairly new to spatial analysis and I am trying to create a map of the spatial distribution of pollution in the UK using publicly available data retrieved from https://uk-air.defra.gov.uk/data/pcm-data.

The files are all downloadable as .csv and provide the x and y coordinates for the centroid of each grid cell.

I tried to import them on QGIS 3.10 in the following way: Layer > Add Layer > Add Delimited Text Layer... Once I select the file, QGIS automatically recognizes the centroids as my x and y coordinates. However, when I try to plot them, my pollution concentrations do not overlap with UK geographical boundaries.

My ultimate goal is to join attributes from different datasets by location so I would need help understanding how to properly import my pollution csv files so that they overlap with my other shapefiles.

  • 3
    Check the CRS of your data and set it accordingly in the CSV import dialog
    – Babel
    Commented Dec 20, 2020 at 9:06
  • 2
    The defra data CRS seems to be british national grid EPSG: 27700
    – ian
    Commented Dec 20, 2020 at 9:37
  • Many thanks to both of you, babel and @ian. I tried to import the csv file by setting EPSG: 27700. However, my pollution data still does not overlay with UK boundaries when I check with OpenStreetMap. Is there something else I am missing out here? Commented Dec 20, 2020 at 9:45
  • There is a post on github that seems to describe a similar issue. github.com/qgis/QGIS/issues/30643 you might be missing the Grid OSTN15_NTv2_OSGBtoETRS.gsb file too. It can be obtained from the proj-datumgrid-europe package at download.osgeo.org/proj/proj-datumgrid-europe-latest.zip. Unzip the file and put the .gsb file in the 'proj' folder under your QGIS user profile folder.
    – ian
    Commented Dec 20, 2020 at 15:20

1 Answer 1


Your data contains a few header lines that probably cause some problem. When importing, be sure to set the Number of header lines to discard to 5 (or as many lines there are before the actual data starst) and check the box near to First record has field names.

Check out the preview at the bottom of how your data are imported. Does it look similar? Each column should be placed in a separate cell. Be sure to set the right delimiter above in the File Format section, comma in this case. Also set the CRS to EPSG:27700 as proposed by @ian. Check if x and y coordiantes are set to use the correct fields and change it manually, if necessary.

When I do this, it works perfectly with a sample download of the site you mentioned.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.