0

I have created a Web AppBuilder web application and downloaded. And published it on IIS. When I visited the application via browser the login popup is appearing like following.

enter image description here

But this popup is appearing every time when I refreshed the page. The sign in info does not saved on browser. If I do Map share settings for everyone, the popup does not fire. I actually hope to redirect me portal login page. How can I solve this problem?

4
  • Are all the services, web map, and WAB shared to everyone (aka public)? Otherwise you will see this popup. Dec 22, 2020 at 18:02
  • @Tigerwoulds But I need secure application. My services are secured and using proxy. Users should be log in my application.
    – barteloma
    Dec 22, 2020 at 18:48
  • Does the application ask for credentials after say some fixed duration even without refreshing? And let me know the browser you are using? Dec 22, 2020 at 19:27
  • @YogeshChavan I am using chrome or mozilla, but same result. If I do not refresh the page applicaiton does not ask credenntials. Actually I hope to redirect me portal login page. But appears a popup.
    – barteloma
    Dec 22, 2020 at 20:08

2 Answers 2

1

For Chrome

To avoid the problem with the popup asking for credentials the following setting is changed to get it working - Turn off Extended Protection on the server in IIS see steps below:

  1. Start > Administrative Tools > IIS Manager
  2. Expand: <server-name>, Sites, Default Web Site, and adfs
  3. Select the ls application and double-click Authentication
  4. Select Windows Authentication and select Advanced Settings
  5. Set Extended Protection to Off and click OK

Check if this works for you.

1
  • But this pop is not for windows credentials. It is from application side.
    – barteloma
    Dec 23, 2020 at 8:08
0

Bit late on this one but I was able to get the OAuth sign in modal to popup instead of the standard ArcGIS sign in popup in your screenshot.

  1. Create and download a WAB app from Portal

  2. Create a new website on my IIS and configure DNS - it should have a url like https://mywebsite.com/appname

  3. Copy and unzip the WAB download from step 1 to my new IIS site

  4. Add a new web application item in your Portal/AGOL with the URL of your locally deployed app. This item will function as a placeholder for your locally deployed app

  5. Go into the new app's settings (from step 4) and click Register at the bottom to generate an AppId

  6. Copy the appId into your locally deployed app's config.json in the appId property

  7. Set the redirect URI(s) to your app. In my case it was https://mywebsite.com/appname

This displayed the OAuth login popup to sign into Portal and persisted throughout the user's browser session.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.