1

I am trying to merge a 10m DEM with a 30m DEM (10m DEM is a sub area of the 30m DEM). Both DEMs have the same projection and nodata value. I create a .vrt file:

gdalbuildvrt test.vrt *.tif -resolution highest -r cubicspline

That works fine, but at the border from high to low resolution, I get this artefacts: enter image description here

Offset is not consistent: enter image description here

10m data only doesn't produce any artefacts at the image border: enter image description here

The first image shows hillshades I generated from the test.vrt. I couldn't find any solution to avoid getting this line at the transition between 10m and 30m data. The 10m data comes from an airborne laser, the 30m from satellite radar. So I guess only because of this different sources, the values are different and produce a gap.

Is there a possibility to tell GDAL to blend the datasets into each other (only at the outline of the 10m dataset)?

16
  • What is your data source? Where is the border between the two DEM?
    – Erik
    Jan 4, 2021 at 14:17
  • The border between the two DEM is the line where the red arrow points to. The data source is 10m: kartkatalog.geonorge.no/metadata/dtm-10-terrengmodell-utm33/… and 30m: lpdaac.usgs.gov/products/astgtmv003 I aligned the projection and the nodatavalue before merging both datasets.
    – Andreas
    Jan 4, 2021 at 14:37
  • 1
    Since your datasources used different CRS, they most likely had different reference points/level for elevation above sea level. You need to determine this difference and recalculate one of the two DEM.
    – Erik
    Jan 4, 2021 at 14:42
  • 1
    Something else to consider: your source rasters may not be perfectly aligned ("snapped") with each other in X/Y, even though they are projected to the same CRS. Check out the Align Rasters tool.
    – Stu Smith
    Jan 8, 2021 at 17:36
  • 1
    gdalwarp has a -cblend option to blend together datasets using a vector cutline, you could play with that
    – mikewatt
    Jan 8, 2021 at 19:42

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.