2

I'm trying to incorporate the sentinel definitive surface reflectance imagery into my project as sourced from the Digital Earth Australia OWS server (https://ows.dea.gov.au). I'd like to be able to view the different images over time using the Temporal manager, but QGIS seems to always be displaying the latest image rather than the image from the date range set in the Temporal manager.

QGIS version: 3.16

Data source: https://ows.dea.gov.au, product(layer): s2a_ard_granule_nbar_t

I have tried playing around with the temporal settings on the layer properties and then used the temporal manager to set the project temporal settings but no joy - it still just displays the latest imagery.

I have tried setting a static WMS-T temporal range to be just a single date (to force it to a particular date). That didn't work.

As an aside, I cannot seem to be able to set the "Pass project temporal range to provider" - it is telling me that the option is disabled because the project temporal range is not valid. But I've set the project temporal range to be a single date to keep things simple. I'm not sure if this is the heart of the problem.

I know the data source supports time based queries as I can access them via a browser. So I'm confident that the issue is in QGIS (either my configuration or an issue with the code).

The only way I've managed to hack this to work is to hard code a TIME=2017-08-25 parameter as part of the original definition of the WMS interface, and then tell it to "Ignore GetMap/GetFile URI reported in capabilities". This gets me the image from the specific date, but is not particularly workable if I want to be able to use the time slider in the Temporal manager to change the date.

Any advice on how to get this configured correctly?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.