1

I modified my repository like this:

deb https://qgis.org/ubuntugis xenial main
deb-src https://qgis.org/ubuntugis xenial main

Then:

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable

Finally:

wget -O - https://qgis.org/downloads/qgis-2017.gpg.key | gpg --import
gpg --fingerprint CAEB3DC3BDF7FB45^C

I got a lot of broken packages:

Obj:1 http://mirror.cedia.org.ec/trisquel.packages flidas InRelease
Obj:2 http://mirror.cedia.org.ec/trisquel.packages flidas-security InRelease
Obj:3 http://mirror.cedia.org.ec/trisquel.packages flidas-updates InRelease
Obj:4 https://qgis.org/ubuntugis xenial InRelease 
Obj:5 http://mirror.cedia.org.ec/trisquel.packages flidas-backports InRelease 

Leyendo lista de paquetes... Hecho
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias   
Leyendo la información de estado... Hecho

No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».

La siguiente información puede ayudar a resolver la situación:
Los siguientes paquetes tienen dependencias incumplidas:
 python-qgis : Depende: libqgispython3.4.4 pero no va a instalarse
               Depende: libqgis-analysis3.4.4 pero no va a instalarse
               Depende: libqgis-core3.4.4 pero no va a instalarse
               Depende: libqgis-gui3.4.4 pero no va a instalarse
               Depende: libqgis-server3.4.4 pero no va a instalarse

 qgis : Depende: gdal-abi-2-2-2 pero no es instalable
        Depende: libgdal20 (>= 1.9.0) pero no es instalable
        Depende: libqgis-analysis3.4.4 pero no va a instalarse
        Depende: libqgis-app3.4.4 pero no va a instalarse
        Depende: libqgis-core3.4.4 pero no va a instalarse
        Depende: libqgis-gui3.4.4 pero no va a instalarse
        Depende: qgis-providers (= 1:3.4.4+24xenial-ubuntugis-1) pero no va a instalarse

 qgis-plugin-grass : Depende: qgis-provider-grass (= 1:3.4.4+24xenial-ubuntugis-1) pero no va a instalarse
                     Depende: libgdal20 (>= 1.8.0) pero no es instalable
                     Depende: libqgis-app3.4.4 pero no va a instalarse
                     Depende: libqgis-core3.4.4 pero no va a instalarse
                     Depende: libqgis-gui3.4.4 pero no va a instalarse
                     Depende: libqgisgrass7-3.4.4 pero no va a instalarse
                     Depende: grass760 pero no es instalable

E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.