7

There is an older answer by @underdark to this post: Finding centrelines from polygons in QGIS? She links a QGIS model that apparently was created in QGIS 2.12. It has the file extension .model

When I try to open the model in QGIS 3.16, it appears that only models in the new .model3 file extension can be opened. Other models do not appear in the opening dialog and thus can't be selected. I tried to simply change the file extension, but that did not work. When trying to open it, I get an error: model could not be loaded.

Is there a way to convert the model to run it in newer QGIS versions?

  • Have you tried to simply change the extension? If so, what happens when you try to run the model? – Erik Jan 14 at 10:28
  • Yes, that's first thing I tried, it did not work. – babel Jan 14 at 10:40
  • Then you probably have to recreate the model - and you could add it to that question, or edit @underdark's answer. – Erik Jan 14 at 10:44
8

Processing in QGIS 3 was refactored a lot and many algorithms were changed. So it is not possible to covert old models into new format. You need to recreate it.

says Alexander Bruy, QGIS contributor, core developer and translation team lead, in this post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.