2

I am using: QGIS 3.10.13 (64 Bit)

My machine: OS: Windows 10 Home, version 20H2, OS build 19042.746 Installed RAM: 12.0 GB ( 11.9 GB usable) Processor: Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz, 2201 Mhz, 6 Cores
Graphic card: NVIDIA Geoforce GTX 1060 Device: Asus Tuf Gaming FX504 Series

All the data is on my laptop. I am not using any data located on a server and I am not connected to a server.

I had QGIS 3.4 installed on that same laptop for a whole year. It worked fast and was very stable. I updated to 3.10.4 and it suddenly became very slow. The software and projects open fairly fast, but almost everytime I click on a menu Item or an Icon in QGIS it takes 20-100 seconds for the software to respond. Often I also get the message that qgis-ltr-bin.exe is not responding.

Here is what I tried so far:

Uninstall 3.10.4 and re-install 3.4 - the issue did not get fixed.

Uninstall 3.4, install 3.10.13 and clear the user profile in the App data/ roaming/ Qgis/ Roaming folder - the issue still remains. I have tried this 3 times and QGIS still ends up being very slow.

I have tried opening different projects and creating new projects. QGIS still seems to run very slow and makes it impossible to accomplish my GIS based work.

I do not know what else to try. Would anyone have any suggestions what to check for?

  • Could you try launching qgis from a cmd window and append the parameter `--profiles-path C:\temp\qgis`? – bugmenot123 2 days ago
  • Sorry, I forgot to add that you need to navigate to the directory where the qgis-ltr-bin.exe is first. – bugmenot123 2 days ago
  • Thank you. I successfully launched QGIS from the command window. How can I apend the parameters? thank you. – Sim_Ottawa 2 days ago
  • You can just add them when launching, so instead of just entering qgis-ltr-bin.exe and hitting the Enter key, you enter qgis-ltr-bin.exe --profiles-path C:\temp\qgis and then hit Enter. – bugmenot123 2 days ago
4

I've also had my share of QGIS slowness troubleshooting. Here are things I try; some probably don't apply directly in your situation but summarizing for when others have the same question.

  1. Look at the Log messages (bottom right) in case there is some meaningful error message that provides a clue what to fix.

  2. Try with new, empty user profile, in case something has gotten corrupted or an installed plugin is messing something up. (Sounds like you've done this)

  3. Try toggling OpenCL acceleration under Settings > Acceleration. It's experimental, and sometimes doesn't seem sticky the way you had it (or maybe user error).

  4. Try closing the Browser panel. There is a known issue in some recent versions of QGIS where Browser slows things down to a crawl accessing network drives/shares, especially when they are offline. (Editing to add: See https://github.com/qgis/QGIS/issues/33164 and https://github.com/qgis/QGIS/issues/33778 for more details and workarounds for this issue.)

  5. Try reinstalling, in sequence, i) QGIS, ii) the whole dependency tree (e.g. GDAL, proj, ... - full OSGeo4W if on Windows), iii) QGIS one minor version back (in the OSGeo4W installer), iv) The other one of QGIS release vs LTR (you're using 3.10.13 LTR, so for you it would be 3.16.2 now or 3.16.3 next week; for others or at different times it might go the other way), v) The dev weekly or daily version. This fiddling with versions is in case a recent version has mucked something up the previous one (or LTR) had fine, or conversely if it's due to a bug recently fixed but not yet in your usual release branch.

The remaining apply if you can get QGIS working on a really simple brand new project and the issues surface on your existing, more complex project(s).

  1. Turn off internet and restart QGIS. You'll get error messages about remote layers not being available. Keep them, but see if your projects speed up; if so it's a problem loading some slow remote layer.

  2. Try vacuuming local databases (e.g. gpkg) you use in your projects

  3. Try rebuilding a problematic project by starting 2 instances of QGIS, the old project in one and a blank new project. Drag and drop all layers into the new one to see if project corruption was slowing you down. (If you do have a corrupt project and rebuild it, you'll have to worry about transferring settings, layouts, ... for now you just want to see if things get fixed)

  4. Like 7, but copy over one layer at a time to find what has become problematic. Then you can debug that layer. In my recent instance, a layer had invalid code in some data-driven expressions. In previous QGIS versions, those expressions were ignored, but somewhere between 3.10 and 3.16 they instead made QGIS run super-slow. Don't know why, but fixed it.

Good luck!

  • 1
    Thank you. I really appreciate. I am going to try these tips today. – Sim_Ottawa 2 days ago
  • 1
    Wow!! It seems that simply closing the browser Panel has vastly improved the responsiveness of QGIS. I will be working with QGIS for the rest fo the day, so I will see how it behaves longer term, but so far I have seen a huge improvement. I would have never thought that the browser panel being left open would cause such a slowdown. Has a fix been found for the Browser issue? Thank you very much for your advice. – Sim_Ottawa 2 days ago
  • 1
    @Sim_Ottawa, happy it helped. I have hunted up and added to my answer the bug reports threads on the Browser issue. It seems to have been around for a while, but is sporadic -- and not yet fixed. There are workarounds however mentioned in the threads I added. – Houska 2 days ago
  • 1
    Great, Thank you very much. I will check those bugs reports. – Sim_Ottawa 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.