3

I have tried to install the Minkowski fractal dimension calculator via the QGIS Plugin Repository, but got this error shown in the screenshot.

enter image description here

2
  • 1
    Please add the error messages as text, not picture. Jan 19 at 8:49
  • What does QSettings().value('locale/userLocale') return in QGIS Python Console? Jan 19 at 9:04
3
  • Navigate to PLUGIN_PATH/minkowskiDimCalculator folder using Settings > User Profiles > Open Active Profile Folder.

  • Open minkowskiDimCalculator.py file.

  • Remove these lines:

    locale = QSettings().value('locale/userLocale')[0:2]
    locale_path = os.path.join(
        self.plugin_dir,
        'i18n',
        'MinkowskiDimCalculator_{}.qm'.format(locale))
    
    if os.path.exists(locale_path):
        self.translator = QTranslator()
        self.translator.load(locale_path)
    
        if qVersion() > '4.3.3':
            QCoreApplication.installTranslator(self.translator)
    
  • Save the file, reopen QGIS, and try again. It worked for me.

Modifying the plugin's code is not a recommended method, but it can be helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.