2

I'm working in QGIS Hannover and have added some vector shapefiles to my project. Some of the data in the files won't show up in the viewport, leaving "holes" in the map. The same file contains both visible and "invisible" data.

A colleague of mine opened them in Geosecma (an ArcMap module) for me. She discovered that the data not showing up was displayed from empty categories in the attribute table. When she changed this, she could view the complete dataset in the viewport. So there's nothing wrong with the data.

I went back into QGIS and tried displaying from every available attribute, using Symbology. I even tried using the exact same file as my colleague instead of my own copy. It did not solve the problem.

I'm at a loss. Any ideas?

6
  • I do believe that the shapefile is corrupted but it is not possible to understand what happens without test data. If you cannot share the data you can try to make a new copy of the shapefile with some ESRI software and/or with QGIS or GDAL and hope that it gets fixed.
    – user30184
    Jan 21 at 8:24
  • 3
    Please provide a screenshot showing the issue, including a snapshot of the layertree showing the layer, as well as explain what you mean by "displayed from empty categories".
    – Erik
    Jan 21 at 8:24
  • Welcome to Geographic Information Systems! Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Your questions should as much as possible describe not just what you want to do, but precisely what you have tried and where you are stuck trying that. Please check out our short tour for more about how the site works
    – Ian Turton
    Jan 21 at 8:27
  • Thank you very much!
    – Sara
    Jan 21 at 9:38
  • 1
    Ok, the problem is probably in your symbology and not in the data. Turn off such symbology.
    – user30184
    Jan 21 at 9:47
1

if the attributes of the none visible shapes are available with in the attribute table then

  1. try to export the file to a CSV or KML or etc and
  2. try to open the new file with in QGIS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.