6

I need to have an outer glow on the entire coastline of my map. The way QGIS creates glow effects with a gradient from alpha=1 to alpha=0 creates a problem, that whenever the glow overlaps with itself because of the geometry of a shape (e.g. bays or islands near the coast), it will reinforce its own strength at the overlapping location (see image). This creates an uneven distribution of the glow effect.

Screenshot of glow styling

I noticed that there are a bunch of different blend modes for the outer glow effect, yet none of them seem to prohibit this kind of self-reinforcement.

How do I resolve this issue?

2 Answers 2

10

You probably use the wrong "Draw Effects" button. There are two "Draw Effects" options.

You should use the one under "Layer Rendering".

enter image description here

You may want to review this post: Why are there two Draw Effects buttons in Layer Styling Panel in QGIS?

1
  • thank you for the detailed visual explanation!
    – nichomeso
    Jan 22, 2021 at 14:47
6

Choose your glow in Render-Settings for your layer, so it renders for the whole layer, not for each geometry:

enter image description here

For the example below I am using these settings:

enter image description here

As you can see:

enter image description here

1
  • thank you worked like a charm!
    – nichomeso
    Jan 22, 2021 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.