I am unable to activate cloned copies of the default ArcGIS Pro python environment, receiving an error message that required packages are missing.

I am using ArcGIS Pro 2.7.0.

I am trying to create a new ArcGIS Pro python environment. It seems the best way to do this is to clone the default environment, and then add packages using the GUI package manager or conda as necessary.

As seen in the picture below, I have 3 environments - sort of. The test environment was created by manually copy and pasting the default python environment folder to the root directory of my C:\ drive.

The arcgispro-py3-clone environment was created by clicking the clone default button at the top of the window seen in the image below.

3 environments

It seems like the environments were created correctly at first, but they're unable to be activated.

To try activate the test environment, I click the radio button next to the test environment option.

Activate test environment

Now I click OK in the bottom right.

enter image description here

A progress bar cycles for 5 to 10 seconds, and then I receive the following error:

Failed to set as active. Environment must have required packages for ArcGIS Pro.

enter image description here

I get the exact same error when trying to activate the arcgispro-py3-clone environment that was created using the Clone Default button as described above.

The error message makes me think that somehow my default arcgispro-py3 environment is missing packages. To try and fix that, I uninstalled ArcGIS Pro completely, as described in this ESRI blog post. Then I did a clean reinstall with all the default setup options, default install paths, etc. I should also note I have tried restarting ArcGIS Pro multiple times, and have tried running as administrator as well.

ArcGIS Pro indicates that my default environment has 183 installed packages. enter image description here

I have tried to find a list of the default packages required for ArcGIS Pro so that I could try and install everything to a cloned environment. I haven't been able to find a complete, or even partial list.

I have tried to google solutions for the exact error I'm getting, like ArcGIS Pro python environment "Failed to set as active. Environment must have required packages for ArcGIS Pro." When I include quotation marks like that to search for my exact error message, i get 0 results on google.

I am at a loss at this point, but I think a first step in the right direction would be if someone could examine their default ArcGIS Pro python environment, and verify if they have 183 installed packages like me. If someone was to report back that they had more than 183 packages, that would indicate that I do indeed somehow have missing packages.

Obviously, that wouldn't actually solve the problem but it might kickstart the troubleshooting process for everyone.

I could post the output of conda list to provide a list of all the packages I have installed to the default python environment. However the output is many many lines, and I'm not sure what the preferred method of posting such a long block of text is here on Stack Exchange.

  • are there other python environments on your machine which are adding themselves to python path? Review the output (from teh Python Command Prompt) when you run python -c "import sys;print(sys.path)"
    – gotchula
    Commented Jan 26, 2021 at 2:42
  • 1
    Did you get your issue resolved?
    – CLJ
    Commented May 19, 2021 at 17:52
  • I am experiencing the same issue. Did you bring this up with ESRI or post it to geonet? Commented May 19, 2021 at 18:22

4 Answers 4


I have found using conda from the command line a more reliable way of cloning an environment. You get to see the status of the cloning. Clone the existing ArcGIS Pro environment with this command

conda create --clone arcgispro-py3 --name arcgispro-py3-clone27

FYI my original environment also has 183 installed packages.


I had the same problem. Its a permissions issue. The way I fixed it was to go to the folder C:\Users{User Name}\AppData\Local\ESRI\conda and right clicked on the envs folder and turned off Read-Only. Then let that change for all subfolders. My clone folder is about 1 GB, while my failed ones were about 29mb, so it wasn't pulling all the data for some reason.
If this doesn't work try opening Pro as an administrator, then copying the cloned environment from your admin user to your regular user and switch to it in pro.


I was seeing the same issue. The environment we are attempting to work in has a Host Intrusion Prevention System(HIPS) rule that is preventing anything from being executed from the TEMP or TMP System directory (C:\windows\Temp). A firewall or antivirus may also cause the same issue.

When we disable HIPS the environment switch succeeds.

The event being blocked in our case is Pro/conda trying to run proswap.bat. Which is similar to the activate.bat process. See conda documentation for more info on this process.

While not directly related, the description of this issue gives a decent overview of what activate.bat is doing that requires the TEMP directory.

The Solution I came up with was to add a New SYSTEM Environment Variable Called TMPDIR which in my case points to a directory other than the C:\Windows\TEMP directory. I used C:\condatemp.

It appears that ArcGIS Pro/conda looks to run items in the following order:

  2. TEMP
  3. TMP

We have successfully tested this method in multiple environments.

The only documentation I found referencing this was here: and somewhat corroborated in the Anaconda Install documentation

I have logged an enhancement with ESRI to add information specifying that ArcGIS Pro EXECUTES proswap.bat from the directory specified by the System Environmental Variable "TEMP".


I don't have enough "reputation" to comment on Mark Bryant's answer above, but I also solved my problem by using the command line instead of the package manager. I followed these instructions:


I suspect that the last step, activating the cloned environment, isn't happening through the package manager.

Be aware, if you switch to the cloned environment in Pro then it will use the cloned environment when you open the command line from Start. Be sure to switch back to the clean environment before closing Pro and opening the command line. Also run everything as an administrator, as others have mentioned.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.