0

I have downloaded a netcdf (.nc) file from here: https://nsidc.org/data/NSIDC-0756/versions/2

In order to display in QGIS I have extracted one variable from it. The file successfully displays in Panoply, and displays projection information in the header for the main file (Polar Stereographic South), but when I load it into QGIS it says it does not have projection info. When I manually define it as Polar Stereographic South, it does not project anywhere close to correctly.

Though the header for the overall file shows projection info, the header for the actual variable does not. I have tried converting to geotiff then loading in QGIS, but it has the same issue.

Header info for file for Panoply: enter image description here

And for the variable

enter image description here

2

Current version of MDAL 0.8.1 (QGIS 3.20) does not support NetCDF format with CF-Convention where there is no mesh defined (only vertices). The relevant enhancement ticket is in the MDAL issue tracker

0

I solved this with two steps.

  1. When extracting the variable in NCO, I also extracted the x,y variables with the -c switch, which also caused to extract 'mapping' variable.

    ncks -c -v bed,x,y mynetcdf.nc mynewnetcdf.nc

  2. when loading to QGIS it still did not work when adding as a mesh layer. For reasons I do not understand, it had to be drag-and-dropped into the map.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.