0

I am trying to import arcpy into Spyder. I saw ArcPy import arcgiscripting relating to this, but I'm using ArcGIS Pro 2.7, not ArcMap. My original Python is 3.8 but for the environment that I created to run arcpy in Spyder, I installed Python 3.6 (following an error I got previously). This is similar to what was suggested at this answer to Importing arcpy in Spyder, but when I install Spyder on the newly-created anaconda environment, I try to import arcpy into Spyder and get the following error:

 File "C:\Users\anner\AppData\Local\Programs\ArcGIS\Pro\Resources\ArcPy\arcpy\geoprocessing\_base.py", line 14, in <module>
    import arcgisscripting

ImportError: DLL load failed: The specified procedure could not be found.

I've tried updating the Python interpreter in Spyder to the python.exe that was automatically installed with ArcGIS but got this message

enter image description here

Any ideas?

1

It sounds like you are using the wrong version of Spyder.

I created a tutorial on Installing spyder IDE for ArcPro at GeoNet that you can try to follow to accomplish this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.