0

I have the new Macbook Pro M1 with BigSur. I have installed miniforge via new Homebrew (compatible for M1 chips). Then I created a new conda environment and then installed few libraries, one of them was GeoPandas (conda install geopandas). However, it seemed to failed fetching it and got this error:

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versions

Despite the error, I went ahead and created a new Jupyter notebook and wrote only one line "import geopandas as gpd" and did not get any errors. Then I wrote a second line "gpd.read_file('shapefile.shp')" and got this error:

AttributeError: module 'geopandas' has no attribute 'read_file'

In addition, I also tried doing this via pip (before I even installed miniforge but got the same error eventually).

Can I just check, are people using GeoPandas in M1s without issues or am I doing something wrong?

3
  • 2
    We will definitely need more information about your system, versions of the softwares you are using, the sequential procedure you are trying to apply, you and so on. Simply imagine yourself reading the question without knowing all what you know about your environment; would you be able to answer it? – s.k Feb 6 at 9:23
  • Hi sk, apologies. I have re written the question. Does it make sense now? – user14903989 Feb 6 at 12:02
  • Apparently a way to do this (I don't use Macs so can't be more specific) is to setup your conda & envs in emulation stackoverflow.com/a/65930795/737471 – user2856 Feb 7 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.