3

I have a shapefile with almost 1000 polygons (each polygon representing a farm). There are a lot of topological errors (gaps/slivers and overlaps between polygons). Below is a "zoomed in" example. I am using QGIS 3.10.

Example of gaps and overlaps in a farm shapefile

I tried out the GRASS "v.clean" function as well as the snapping tool in QGIS and have two questions:

  1. Using "v.clean", which specific tools should I use to remove the gaps / overlaps and how can I determine the threshold value that I should use (where applicable)? I tried using "break", "rmdupl" and "rmarea" (using various different threshold values), but I do not see any changes in the cleaned output (the gaps / overlaps remain). What reasons could there be that this is not working?

  2. Using the snapping tool, how can I move an entire selected polygon (yellow on the map) to match up with the borders of the adjoining polygons, instead of snapping each and every vertex to each other? It looks like the entire selected polygon just needs to be moved, and the gaps and overlaps will be eliminated automatically. Furthermore, I am worried that if I start snapping the segments/vertices, then the shape of the polygon will change if I do it incorrectly (and it will take a lot of time doing this for the entire farm shapefile!).

I am investigating the movement of animals in relation to farm boundaries, so it is vital that the boundaries of the polygons do not change shape.

Here is a link to my farm shapefile

Please note that I am a QGIS beginner, so I need an explanation that is not "too advanced".

3
  • 2
    With v.clean, the snap option will be the best tool. As your polygons have 80~90m gaps, you could try 100m as the threshold. Having said that, I would suggest (1) to fix geometries first (Vector > Gemetry Tool > Check Validity), then (2) Use Snap geometries to layer tool (Processing Toolbox > Vector geometry) on the fixed layer.
    – Kazuhito
    Feb 6 at 15:29
  • For snap geometries to layer tool, a few extra questions: Do I use the farm layer as both input layer and reference layer? What would you suggest for the behaviour selection?
    – Stef
    Feb 6 at 18:06
  • 1
    (1) Yes, the both of input and reference layers are your farm layer. (2) Behaviour I recommend: Prefer aligning nodes, don't insert new vertices.... (3) If you see errors related to the geometry issue, click on the Advanced options (wrench icon) and choose Skip (ignore).
    – Kazuhito
    Feb 6 at 23:42
1

The solution to my problem was that I needed to use the snap geometries to layer tool in the Processing Toolbox. I used the farm shapefile as both the input and reference layer > Set Tolerance and Behaviour (for this I used snap to anchor nodes (single layer only)) > Run. Then I went to Vector > Check Geometries to make sure all topology errors were removed. For more help on the Geometry Check tool, follow the link to a webpage that was very useful to me: Geodose webpage (you will find info on Geometry Check if you scroll to the bottom).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.