0

I am trying to install QGIS on my Linux Mint 20.1 Cinnamon, using this: https://freegistutorial.com/how-to-install-qgis-on-linux-mint-19/

But when trying to

sudo apt-get install qgis python-qgis qgis-plugin-grass

it says python-qgis wasn't found. I tried sudo apt-get install qgis python3-qgis qgis-plugin-grass it showed it depends on following packets : libgdal20 libqgis-3d3.16.3 libqgis-analysis3.16.3 libqgis-app3.16.3 libqgis-core3.16.3 libqgis-gui3.16.3 python3-qgis qgis-providers qgis-plugin-grass grass740 libgdal20 libqgis-app3.16.3 libqgis-core3.16.3 libqgis-gui3.16.3 libqgisgrass7-3.16.3 . I tried install them all together with apt-get install it showed libgdal20 , grass740 ,libgdal20 (no installation candidate exits ) what is that now , I deleted those 3 packets, it showed me another dependecy problems. here is for sudo apt install qgis qgis-plugin-grass :

You have requested an impossible situation or when you have the Unstable distro use that some required packages still have not been created or have not yet left Incoming. The following information may help you resolve the situation:

The following packages have unfulfilled dependencies:
 qgis: Depends on: libgdal20 (> = 1.8.0) but cannot be installed
        Depends on: libqgis-3d3.16.3 should not be installed
        Depends on: libqgis-analysis3.16.3 should not be installed
        Depends on: libqgis-app3.16.3 should not be installed
        Depends on: libqgis-core3.16.3 should not be installed
        Depends on: libqgis-gui3.16.3 should not be installed
        Depends on: python3-qgis (= 1: 3.16.3 + 28bionic) but should not be installed
        Depends on: qgis-providers (= 1: 3.16.3 + 28bionic) but should not be installed
 qgis-plugin-grass: Depends on: qgis-provider-grass (= 1: 3.16.3 + 28bionic) should not be installed
                     Depends on: but grass740 cannot be installed
                     Depends on: libgdal20 (> = 1.8.0) but cannot be installed
                     Depends on: libqgis-app3.16.3 should not be installed
                     Depends on: libqgis-core3.16.3 should not be installed
                     Depends on: libqgis-gui3.16.3 should not be installed
                     Depends on: libqgisgrass7-3.16.3 should not be installed
E: Problems cannot be corrected, you have defective packages 

when even try install these dependecies they count on others

3
  • 1
    Have you tried python3-qgis ? – Leon Powałka Feb 10 at 12:44
  • I reedited the question – sumer fattoum Feb 12 at 7:32
  • I could at end install it by : ~ flatpak install flathub org.qgis.qgis , ~flatpak run org.qgis.qgis – sumer fattoum Feb 12 at 8:42
0

TL;DR: The plugin is called qgis-python, but please, check if you are installing the newest version. Normally, manually installing dependencies is not necessary: these are fetched by your package manager (apt)

The source you refer to mentions that QGIS 3.4.1 just came out. This is horribly outdated. In stead, the official QGIS website describes how to install QGIS 3.16.x on linux. Since Linux Mint is just another flavour of Ubuntu, so those instructions should apply. (please correct me if I'm wrong here) So:

  1. install dependencies:
sudo apt install gnupg software-properties-common
  1. get signing key:
wget -qO - https://qgis.org/downloads/qgis-2020.gpg.key | sudo gpg --no-default-keyring --keyring gnupg-ring:/etc/apt/trusted.gpg.d/qgis-archive.gpg --import
sudo chmod a+r /etc/apt/trusted.gpg.d/qgis-archive.gpg
  1. add repository for 2.16:
sudo add-apt-repository "deb https://qgis.org/debian `lsb_release -c -s` main"
  1. install qgis (and optionals)
sudo apt update
sudo apt install qgis qgis-plugin-grass

optional:

sudo apt install qgis-python

happy GIS-ing!

2
  • hi, thnx for your reply,I tried instructions from site which are the same as yours, and still dependency problem with packets like libqgis-app3.16.3, libqgis-core3.16.3 , libgdal20 , libqgis-3d3.16.3....etc, how can I check if I am installing the last version since it says qgis-python and not qgis3-python , while I tried also qgis3-python and didn't work – sumer fattoum Feb 12 at 7:30
  • I could at end install it by : ~ flatpak install flathub org.qgis.qgis , ~flatpak run org.qgis.qgis – sumer fattoum Feb 12 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.