0

I'm still quite new to GIS. I am trying to sync the CRS of some vector data I retrieved in the field with some raster Digital Elevation Models I have downloaded. The vector data is a gpx. file referenced to WGS 84. The raster images do not appear to have an inherent referencing specification.

enter image description here

When I assign both to WGS84 it doesn't work. I have tried reprojecting the raster data.

enter image description here

I have tried some different things, but my vector and raster data are appearing in entirely different areas of the map field. When trying to assign both to WGS 84, the coordinates of my vector data is: WGS: 151.93694,0.00000. The coordinates of my raster data are about:86.427034,0.000000

I have also tried to set both the vector and raster files to GDA94 referencing and when reprojecting the vector data I ran an error:

enter image description here

Thanks for any help you can offer and pls let me know if you would like more specific info.

UPDATE: this is the transrmfoation prompt that comes up when I add the raster (GDA94) files to the project after having added the vector (WGS86) data with the CRS set to 'default to layer'.

enter image description here

8
  • 2
    Please check the "spatial reference" tab of the DEM-website for the CRS used. Since QGIS is able of "on-the-fly"-reprojection, you don't need to "match" the CRS. Simply load the data using the correct CRS for each layer, then they will be placed in the same location, if there's indeed a spatial overlap. – Erik Feb 10 at 12:10
  • Simply load the data to QGIS, don't change anything after download. Drag and drop the files in the main window and they should appear in the right place. – Babel Feb 10 at 12:49
  • Thanks @Erik, I checked the raster spatial reference tab that I didn't see before and it was as I suspected--GDA94. I have just added the files and an automatic prompt comes up for me to alter the referencing of the vector data to be GDA94. I still have a similar problem--things are not lining up. – Curtis Feb 11 at 13:29
  • I have noticed 'on-the-fly' get mentioned a lot, but I cannot see this as an option to select when looking at my CRS settings. For 'CRS for projects' I only have two options: use CRS from first layer added, or select a default CRS. For 'CRS for layers' I have 4: leave as unknown, prompt for CRS, use project CRS, use default layer CRS. Do you know what the issue could be? I am using QGIS 3.16.2 as a heads up. – Curtis Feb 11 at 13:29
  • This isn't an option you can turn on and off (at least not easily), this is an inherent feature of QGIS. The CRS for the layers should always be the default layer CRS. – Erik Feb 11 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.