1

I have nine adjoining DEM layers (3x3) styled as 'hillshade' but there are some obvious artefacts, particularly where tiles meet. I've exported the hillshade layers to TIFFs in QGIS using the 'rendered image' option, edited them in Photoshop to remove the artefacts, and then imported the updated files as raster layers in QGIS. However, QGIS is insisting on applying some kind of Style to the new TIFFs, instead of just rendering them the same as I see in Photoshop. They therefore look completely different to the originals, which were the style I wanted but had artefacts.

The top half of the image below is an original DEM layer with 'hillshade' style, while the bottom is a TIFF from Photoshop.

Difference in styling between original and imported layer

I had naively assumed that I could just re-import them exactly as they showed on-screen in PS.

Am I doing something wrong, or is this simply not possible?

I guess I'm looking for something like an option in the "Render type" box for layer style which is just 'unaltered' but I don't know how to say that in QGIS-speak!

I'm new to GIS generally, so may be missing something obvious, but I've searched high and low and can't find what the problem is.

If I copy and paste the style onto the newly-imported TIFFs, it seems to just add the hillshade on top of a TIFF which is already hillshaded, so I get double-hillshade (applied to the bottom half below):

enter image description here

1
  • Presumably you can't do the editing in Photoshop on the raw data? Feb 19 at 19:48
4

Instead of using Photoshop, you can fix the problem directly on QGIS.

Hillshade rendering (or any other raster rendering) happens individual layer by layer, as each layer know nothing about their neighbours.

You can bundle the all 9 rasters in a single layer by creating a virtual raster. You have a tool to create the virtual raster in the processing toolbox.

https://docs.qgis.org/3.16/en/docs/user_manual/processing_algs/gdal/rastermiscellaneous.html?highlight=build%20virtual%20raster#build-virtual-raster

Make sure to disable the place each raster in a separate band option.

After that, you can use the hillshading renderer on the output.

Moreover, you can tweak the resampling options of the layers. Changing the zoom in and out ressampling to Cubic or Bilinear should give you a better result.

https://docs.qgis.org/3.16/en/docs/user_manual/working_with_raster/raster_properties.html#resampling

3

If I understand correctly:

  • You loaded the DEMs into QGIS, you were happy with the styling
  • You weren't happy with the artefacts, so you did some polishing in Photoshop
  • When loading the polished-up rasters, the styling in QGIS is different from what it was originally.

If that's the case, you should be able to apply the styling of your "old" layers to the new one.

Go to the layers panel, right click the layer with the desired styling, and find Styles > Copy Style

Copy layer style

Next, go to your new layer, right click and find Styles > Paste Style.

Of course, there should also be a way to configure your styling from scratch, but this seems the most direct solution given your description.

3
  • You do indeed understand correctly! :) Glad I managed to explain what I meant. Unfortuantely copying styles seems to just double the hillshade effect, because it was already hillshaded when I exported the rendered image to TIFF. I've updated the question with an example image.
    – HaydnW
    Feb 18 at 23:03
  • Okay, I've read your edit, I'm still having some trouble figuring out what you did exactly. Where are the green colors coming from? If you right click the layer, and find Properties, Symbology, what does it say for the Render Type for your layers? I'm assuming they should all be set to Hillshade... Feb 18 at 23:09
  • Have you tried editing the DEM's in Photoshop to remove/minimize artifacts before applying hillshade? Feb 18 at 23:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.