I've been trying to run several hydrological algorithms (Strahler, Fill Sinks etc) from SAGA in QGIS ltr and I keep running into the same error:

The following layers were not correctly generated.

  • C:\Users\HANNES~1.BYS\AppData\Local\Temp/processing_54346125960a43788d22bdb05d351ac6/a33e5a9db9f7418e8b1c75f5b08eac12/STRAHLER.sdat
  • C:\Users\HANNES~1.BYS\AppData\Local\Temp/processing_54346125960a43788d22bdb05d351ac6/ffe2e0caaf2c4a5a9f12648fa77f4364/STRAHLER.sdat
You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm.

I've reinstalled QGIS via OSGeo4W and stand alone installer and I've also reinstalled SAGA.

Here is a picture of my workflow:

enter image description here

  • Remove the special signs (ä,ö,ü) from your file path & name and you should be fine.
    – Erik
    Commented Feb 19, 2021 at 10:24
  • Doesn't seem to work - still get the same error.
    – Hansays
    Commented Feb 19, 2021 at 10:47
  • 1
    I think, It is not error. I mean your outputs are correct. Did you save the outputs on disk or left them blank while setting parameters? Saga asks you to save them to disk. Otherwise(when you save it temporary), it says "not correctly generated".
    – Gakovî
    Commented Feb 19, 2021 at 18:53

1 Answer 1


So I've managed to solve the problem (sort of).

It seems that SAGA doesn't like input in the form of GeoTIFF and after converting the input to .ASC via GDAL Translate, the algorithms started to work (although still ending with the same error).


After some additional testing, it seems that SAGA is more likely reacting to my specific input of GeoTIFF which are compressed. Now, when I decompress them and keep the file format, it yields the same result as previously listed (the SAGA algorithms produce output but still leaves an error).

  • Are you getting any error messages in the Event viewer such as a Software Restriction Policy blocking part of SAGA or group policy doing the same? I mention this only because one blocked me from running GRASS tools because the temporary cmd file was attempting to run in the user temp folder (which was being blocked) and in searching for answers I recall someone saying they had the same issue with SAGA. You might try running a test GRASS tool to see if it is blocked.
    – John
    Commented Feb 19, 2021 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.