0

We published a project under Ubuntu Server, QGIS, LizMap web client, .. Everything works except the "time manager".

Under the desktop client, the time manager works correctly (for example exp: sequences between the dates 2007-01-01 to 2020-06-01) - therefore functional date format.

However, when it is placed on the server in the right place, it does not work and the dates do not correspond (here 2021-02 -current date/month as start time- to 2021-07).

First, we worked with :

  • Lizmap-web-client version is 3.4.1
  • This is a shp.
  • qgis-server: Installed : 2.18.17+dfsg-1
  • Desktop QGIS 3.16
  • Fields - we tried many formats (raw data : 2007-01-01 to 2020-06-01)
  • Qstring as in the demo > do not work
  • QDate as well yyyy-MM-dd + other date formats as yyyy-MM-dd 00:00:00 > do not work
  • QDate/Time yyyy-MM-ddT00:00:000. > do not work

To solve the time manager problem, we have installed on another system: ubuntu 20.04.2 LTS qgis-server: 3.10.4 = qgis-dekstop 3.10.4 dfsg-1ubuntu2 (current version of ubuntu repository) lizmap-web-client 3.4.1.

While running command below i got the error message below. I check, indeed the vendor directory does not exist in this version of the lizmap-web-client. Do you have an idea ?

php lizmap / install / installer.php - PHP Warning: require (/var/www/html/lizmaplive/lizmap/vendor/autoload.php): failed to open stream: No such file or directory in /var/www/html/lizmaplive/lizmap/application.init.php on line 12

PHP Fatal error: require (): Failed opening required '/var/www/html/lizmaplive/lizmap/vendor/autoload.php' (include_path = '.: / Usr / share / php') in / var / www / html /lizmaplive/lizmap/application.init.php on line 12

if not, can you confirm a qgis-server and lizmap-web-client version that works on a ubuntu server 20.04 LTS?

17
  • Can you add the Lizmap Web Client version ? What is the source of the layer ? A geopackage, shapefile, PG ? Could you press buttons to compute min and max ? What is the description of the field in the "Fields" tab ? – etrimaille Feb 23 at 12:25
  • Hi, Thanks for your quick response. – Water67 Feb 23 at 13:50
  • Hi, Thanks for your quick response. Lizmap Web Client 3.3.6 - this is a shapefile ; I try to change in spatialite but no works - I use 2.18 QGIS Dekstop - so no compute min and max but it works for example on such demo : demo.lizmap.com/lizmap/index.php/view/map/… - I try with qgis 3.14 with min and max - and "invalid format" - I change in Qstring as in the example and modify for many date format - yyyy-MM-dd + other date formats as yyyy-MM-dd 00:00:00 no works - I think it's a detail ... – Water67 Feb 23 at 13:59
  • Please edit your question for adding new information. It's better than commenting. The time manager changed a lot between Lizmap Web Client (LWC) 3.3 and 3.4. I think you should just upgrade first. Let's check after your field type. You can download the earthquake demo on the link you gave. – etrimaille Feb 24 at 2:26
  • Done but no changes - I add details requested in the question; Thanks for your help. – Water67 Feb 24 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.