2

I have recently installed the sen2r plugin in r for extracting level 1 Sentinel-2 images from ESA's Long Term Archive and using sen2cor correction to obtain level 2 scenes.

An issue I face is that the GUI seems to not let you apply sen2cor. It says that level 2 images are required. I have tried to use the standalone sen2cor processor which comes as a part of sen2r() package in R, but not all scenes get corrected.

Does anyone have experienced something similar or can provide guidance with this?

8
  • 1
    Is it a must do step the use of sen2cor over L1C images? You can donwload S2-L2A images, which are already corrected by sen2cor
    – aldo_tapia
    Feb 23, 2021 at 12:13
  • That is true, but S2_L2A images only go back to December of 2018 (at least in Google Earth Engine it shows that) and I am trying to incorporate older images. Unfortunately the OpenHub is down for a few days, so I can't verify this, but I think the older scenes are just L1C
    – AdoMath
    Feb 23, 2021 at 12:48
  • 1
    I used to correct S2 L1C images with sen2cor from CMD/terminal window. I created batch orders in R with paste0, saving the sentences into a batch file. It's kinda easy if you have all the S2 folders in one single folder. I have no experience in the use of sen2r tho, so I can't help you with package usage
    – aldo_tapia
    Feb 23, 2021 at 13:29
  • 1
    Check L2A_Process --help in CMD/terminal window and see if sen2cor is correctly installed
    – aldo_tapia
    Feb 23, 2021 at 13:33
  • 1
    Sadly I don't have it, but you only need paste the L2A_Process --resolution 10 with the .SAFE folders and modify L2A_GIPP.xml file for atmosphere / terrain correction configuration. Check for usage: step.esa.int/thirdparties/sen2cor/2.8.0/docs/…
    – aldo_tapia
    Feb 23, 2021 at 15:04

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.