2

I am using the MMQGIS plugin to join sets of data on QGIS. I have been failing to do this for days on account of the output file location being rejected. This error message appears: Failure creating output file: Creation of data source failed (OGR error: C:\Users\cavca-admin\Documents\imd.shp is not a directory.)

It obviously suggests that I need to be choosing a directory as the output file location but I am unable to do this because it isn't valid. I have tried saving all relevant files in the one directory and choosing a range of file locations but nothing has worked.

2
  • It's a really bad error message from GDAL/OGR and actually means the file md.shp already exists and needs to be manually deleted before running the plugin again.
    – user2856
    Feb 24, 2021 at 3:26
  • Message is bad in this context but if md.shp was a directory then GDAL/OGR would create the output shapefile inside that directory. Perhaps the message could be longer ...is not a directory where new layers could be added.
    – user30184
    Feb 24, 2021 at 6:50

1 Answer 1

0

I had the same issues and what fixed it for me was exporting to .geojson format rather than .shp. I am not using .shp otherwise and am not subscribed to any ArcGIS services, so I figured there could be an incompatibility there. However, I cannot explain it technically.

.shp is a proprietary but open file format, so it should work for all of us.

But I am much happier with the GeoJSON layers I have now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.