3

I'm not able to enable Python scripts in the processing toolbox. It should turn up in the toolbox (see the third screenshot).

The Python logo is also missing from the toolbox. Is there something wrong with the settings in the second screenshot?

I tried to write my own custom script. When that failed I exported a model from the models as 'Python Algorithm' but also no success.

Settings

No Python Yes Python

2 Answers 2

1

I'm not sure. But it works right now.

I have 2 separate installations of Python (3.6 & 3.8) in a separate folder.

C:\Python\python36 & C:\Python\python38

Those folders and the script folders are listed in the system variables (2) & (3). I noticed that the C\OSGeoW64\bin (1) folder was listed at the bottom. I now moved this path up.

After a reboot the scripts are visible. System variables

0

The python icon should be enabled automatically when a python script is saved in the location set in the processing options. I found that the only way I could repeat your issue was by removing all scripts from the location I set, leaving it empty. This removed the python icon from the processing toolbox.

To test if I could re-enable the python icon I then exported one of my models from graphical modeller, saving it in the script location, and it has activated the python icon in processing toolbar and is showing the script I exported.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.