I have an odd question from a user in the same goverment that I work for.

When he opens a .MXD-project in ArcMAP a Personal Geodatabase also opens that is not part of the project and does not have any connection join/relates to the project (an LDB-file is created an points to his computer). He removed all his OLE DB-connections and saved the project under a different name but the problem still occurs.

Does anyone have a clue of what's going on here?

I myself think the user opened the PGDB in Access and did something the he shouldn't have.

  • 1
    There might be something from the Geodatabase that is being accesed. Have you looked at the Data Sources tab in the TOC? Commented Oct 30, 2012 at 9:28
  • 1
    My first thought was that there was a Table in the pGDB and that only the "drawing order" rather than "source" view is being looked at to "verify" that the pGDB is not accessed. So I agree with @DevdattaTengshe
    – PolyGeo
    Commented Oct 30, 2012 at 12:18
  • That was my first thought as well, but the user has removed the OLE DB-connection.
    – Andersson
    Commented Nov 5, 2012 at 12:01
  • In this situation, the OLE DB-connections do not matter because this is a personal geodatabase. You don't have to have an OLE DB connection set up to an MS Access database in order for ArcGIS to be able to access it. ArcGIS is using internal drivers to access the PGDB. So the fact that those were all deleted, doesn't necessarily mean all references are gone. Commented Dec 8, 2012 at 0:59

2 Answers 2


Version 9.3x software used a pGDB as its temporary file store; so when you create a MXD it will create a storage location so you are ready to Geoprocess.

In version 10 this changed to a fGDB but this had issues that the MaxSize = 4GB setting was in place as the default.


You can try to repair your MXD: Open your MXD in ArcMap (=ArcMap 1). Open a second instance of ArcMap (= ArcMap 2) with an empty MXD. Copy all layers from the TOC of ArcMap 1 to the TOC of ArcMap 2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.