The recent release of QGIS 3.18 supports point cloud data. As can be seen on the screenshot in the linked Visual Changelog (above), .laz files should be supported.

However, in my installation on Windows 10 (standalone installer) it looks differently: I don't have the option PDAL Point Clouds and EPT Point Cloud in the data source management interface. I only have one entry Point Cloud, see screenshot below. With this option, I am not able to open .laz files. If I select one of the files to open, nothing happens. Only supported format is ept.json as can be seen on the screenshot.

If I just drag and drop a .laz file from the explorer to the QGIS window, I get this error message: [path].laz is not a valid or recognized data source. The same is true when I convert the .laz file to .las unsing lastools.

I also tried different lidar files sources to be sure that the problem is not connected to a corrupted file. I tried e.g. 2010 USGS Lidar data from San Francisco bay area: https://coast.noaa.gov/htdata/lidar1_z/geoid12a/data/1406/

So how can I open a .laz file? I'm not sure if I miss something or if it a bug.

enter image description here

1 Answer 1


Could be wrong but you should reinstall QGIS 3.18 with the new installer. QGIS standalone installers on Windows are all based on OSGEO4W. At the moment, 2 OSGEO4W installers and only the new one allows for point cloud support. See announcement at https://lists.osgeo.org/pipermail/qgis-user/2021-February/048137.html

You may try the new standalone installer based on MSI installer https://lists.osgeo.org/pipermail/qgis-user/2021-February/048199.html

You can also see a video about the new MSI installer by Hans van der Kwast in YouTube https://www.youtube.com/watch?v=wbCbLs_XEMA

  • No point cloud support in current standalone installers according to 1st link It also has PDAL 2.2 which is required for native support of point clouds in QGIS - something that you find lacking in the "old" OSGeo4W repository and in turn in the current standalones. Try the MSI installer: the new standalone installer should support point cloud
    – ThomasG77
    Feb 28, 2021 at 13:44
  • indeed, using the new OSGeo4W installer, adding laz-files is possible. Thanks a lot for hinting to right post, the information is quite hidden.
    – Babel
    Feb 28, 2021 at 14:08
  • 1
    There is a bug tracking this silent fail github.com/qgis/QGIS/issues/41764 Feb 28, 2021 at 15:19
  • 1
    QGIS standalone installer for 3.18 is offline right now "because of some serious issues found after release." Will be back with release 3.18.1 with fixes. So anyhow, right now the only way to install 3.18 is OSGeo4W.
    – Babel
    Mar 1, 2021 at 14:15
  • 1
    Update: QGIS 3.18.1 released with the new installer and fixes for 3.18 serie twitter.com/JuergenEFischer/status/1373923127852474369
    – ThomasG77
    Mar 22, 2021 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.