1

I have defined a WMS-T (WMS + Time) service of GeoTiff files that is working with TimeManager (QGIS 3.4).
The same WMS-T service doesn't work with TemporalController (QGIS 3.16).
TemporalController doesn't through any error but doesn't show any image.

Testing WMS-T service with GetMap request in web browser with different values of TIME parameter return correct images, so the WMS-T service is working fine.

With TimeManager (QGIS 3.4) I set datetime format to %Y but with TemporalController (QGIS 3.16) I cannot find this option. I have trying different datetime formats like this 'yyyy-mm-dd hh:mm:ss' but TemporalController doesn't work.

What I'm missing here? Any example would be appreciated.

To be more precise, I have this code in mapserver configuration file (.map):

LAYER
        NAME "temporal_serie_raster"
        TYPE RASTER
        STATUS ON

        METADATA
            "wms_title"             "metadata_layer_title"
            "wms_abstract"          "metadata_layer_abstract"
            "ows_extent"            "metadata_layer_extent"
            "ows_srs"               "metadata_layer_srslist"
            "ows_keywordlist"       "metadata_layer_keywordlist"
            

            "wms_timeextent"    "2017/2020"
            "wms_timeitem"      "time"
            "wms_timeformat"    "YYYY"
        END # Metadata
        
        TILEINDEX "tileindex.shp"
        TILEITEM "location"     
    END # Layer 

And 'tileindex.shp' has this content:

enter image description here

This is only a sample code that works with TimeManager, but it doesn't works with TemporalControler. Is it possible to use this 'wms_timeformat' with TemporalControler?

0

Try playing with the Properties>Source settings. That seemed to make my layer magically work.

enter image description here

enter image description here

1
  • Thank you for your answer @cefect! I have tried to set this option in QGIS but still doesn't work. I have add more details to my question. Maybe the problem is time format? – user3446944 Mar 24 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.