0

After successfully loading .laz point cloud data to QGIS 3.18 on Win 10, I am able to show the data in 3D view. However, the data is visualized twice: once as a flat pane with the same symbolization as in the QGIS main window and a second time above with the style defined in the 3D-view tab of layer properties as you can see in the first screenshot.

Is there an option to hide the flat pane of point cloud rendering in 3D views to show only the 3D rendering of the point cloud? There are possibilities to achieve what I want, but only as a workaround. I wonder if there is a propoer function for that.

What I tried: If I uncheck the layer, both visualizations disappear. There is a workaround: creating a white polygon on top of the point cloud layer hides the flat pane, whereas the 3D point cloud is still shown. Another workaround is the symbolization tab in the layer properties. There is no option to get a "zero-style" (like "no fill" if case of vector layers), however if I simply turn the point size to 0, it has the desired effect, see screenshot 2.

enter image description here

enter image description here

1

You can use extent-only renderer as 2d renderer and modify its attributes (colour, etc.)

Alternatively you can create a map theme where the layer will be off, and in 3D settings render this map theme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.