2

Recently QGIS is always very slow (or better freezing) when I am connected to the internet. Some processes take several minutes (even when opening or clicking on a dropdown menu from the taskbar). As soon as I disconnect my internet everything works fine and as usual. Is there an option in the settings to deny QGIS access to the internet. I have already deactivated the display of news and the search for updates. I use QGIS 3.16.4.

6
  • 3
    Have you checked whether any WMS/WFS are being loaded? Have you disabled any plugins?
    – Erik
    Mar 3, 2021 at 11:26
  • what operating system are you using?
    – Ian Turton
    Mar 3, 2021 at 11:33
  • in windows task manager, you can see which program is using your network interface. might it be possible that some other software is doing heavy work whilst beeing connected to the internet (and then releasing your cpu as soon your pc is disconnected from net?
    – sn1ks
    Mar 3, 2021 at 11:40
  • Thanks for the tips. I use windows. WLAN is not on max. capacity, no other programm is doing heavy work while I use QGIS (only firefox, but it's the same with qgis when i close it completely via task manager). I will luck up the plugins. Were i can find them? I don't use any WMS/WFS services. Can I check if any of them are used in the background?
    – Julian
    Mar 3, 2021 at 12:10
  • Found the plugins, only DB Manager, MetaSearch Catalog Client and Processing (everything core plugins as it seems) are activated. Updates are off.
    – Julian
    Mar 3, 2021 at 12:14

2 Answers 2

1

Three things that might cause such a slowdown:

  1. Accessing slow-ish layers over the internet, even if they're not on top/visible. One thing to try is to turn on the Debugging/Development tools panel (right click on the top toolbar to choose what panels are on/off). Then click on the red dot to log network activity. That way you can see what network requests are being sent -- to help you debug what layer(s) might be slowing you down that you might want to remove. This is what it looks like:

Logging example

You will need to do the detective work to figure out what might be triggering each request, but hopefully the URL will help.

  1. Layers or other info that does not load, due to server being down, leading to a long wait before timeouts. Especially if this is a recent server issue, it might slow things down in unexpected new ways. To get around this, you can drastically reduce the Timeout for network requests setting in Settings / Options / Network.

  2. There have in prior QGIS version with long timeout issues in the Browser panel accessing network paths that are offline, which could be resolved by disconnecting the laptop from the 'net so that the request failed immediately rather than timing out. I believe those issues have been fixed, but you could see if you problem goes away by turning off the Browser panel.

0

This Link suggests that you can turn off all the external connections within your desktop manuaally. In my case QGIS is extremely slow, since my pc is connected with multiple external servers. I right clicked in each one in the browser panel in qgis and hid/disconected from the browser.

It is simple but solved my problem.enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.