When trying to install Shapely on my Windows 64bit computer, I cannot get the GEOS library to work.

So far, I have run the OSGeo4W installer from which I installed GDAL (I believe the geos library is included in that package). After that, I checked and I have geos_c.dll on my C:\OSGeo4W\bin directory, but either I have missed some configuration steps or the library does not work.

I need Shapely to work, so I also ran pip install shapely after installing GDAL, and it apparently worked (although it could not find the C library for GEOS).

In my code, I can import Shapely, but when I try to use it, I get an error telling me "geos.dll" is not found.

5 Answers 5


Uninstall shapely and try to install it from here. Hope it helps. It worked for me.

  • This did it. I actually used the same page to download Numpy for an unrelated library, but I didn't see shapely there. Thanks! Commented Nov 1, 2012 at 8:52
  • Thanks! This is AFAIK, the only place you can get a windows installer for shapely.
    – Matej
    Commented Oct 29, 2014 at 20:33
  • just a note for python noobies like myself: the -cpXX- refers to your python version. As of this writing, current versions would be cp27 or cp35.
    – flies
    Commented Nov 23, 2015 at 15:31

I was having the same problem but now everything is working perfectly. You can download the shapely package (in wheel package) from the link shared by Mario Miler (link) Choose you package according to your windows and python version. Download the file, it has .whl extension. It is file format for python Wheel package.

Go to cmd and enter:

pip install wheel

Then cd to the folder where you have downloaded and enter

pip install 'your_package_full_name'.whl
  • where do you find the .whl file? I used the link you give to download shapely but the downloaded file is a zip file, which contains two folders, neither of which seems to contain a .whl file. There is a file called WHEEL with no extension but it isn't something I can run with pip. Commented Nov 28, 2015 at 0:59
  • the file you download from the link is the .whl file. Perhaps you have file extensions hidden in Windows? Open a Windows command prompt in your download folder and you will see the .whl extension. And now you can run the pip command :-)
    – perlyking
    Commented May 25, 2017 at 20:36

The geos_c.dll needs to be in your %PATH%. Per default, OSGeo4W installs directly under C:. If you did that, add C:\OSGeo4W64\bin to your %PATH% : right-click on "This PC"->Advanced System Settings->Environment Varialbes. Setting it only for or system-wide will both work - take your pick. Restart your console and conda install shapely should work.


As of 2020, the recommended method to install Shapely (with it's own GEOS) is simply:

pip install shapely

(you may need --upgrade to get at least version 1.7.0, when Windows binary wheels were supported)

  • Even using the latest shapely it does not work for me. When I run the install I get the error: FileNotFoundError: Could not find module 'geos_c.dll' (or one of its dependencies). Try using the full path with constructor syntax.
    – Carl H
    Commented Dec 22, 2021 at 4:45

Given that you use Conda, a conda installation also works and in the easiest way. Simply try

conda install shapely

It will download and install the correct shapely and geos.

(Posting this, as the wheel from Gohlke did not work either.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.