0

I want to open a GMLAS layer.

When I open the file with:

ogrinfo -ro GMLAS:D:\path\to\file.gml

Output:

INFO: Open of 'GMLAS:D:\path\to\file.gml' using driver 'GMLAS' successful.

...

15: roofsurface (Multi Surface)

...

I tried to open the layer "roofsurface" with Fiona with:

gpd.read_file(r'D:\path\to\file.gml', driver="GMLAS", layer=layer)

Error: DriverError: ... not recognized as a supported file format.

gpd.read_file(r'GMLAS:D:\path\to\file.gml', layer=layer)

Error: unsupported driver: 'GMLAS'

I get the same error in GeoPandas, which internally uses Fiona. Is there another/correct way to open this specific layer in Fiona?

2

Fiona does not seem to support GMLAS driver. See https://github.com/Toblerity/Fiona/blob/master/fiona/drvsupport.py

# Here is the list of available drivers as (name, modes) tuples. Currently,
# we only expose the defaults (excepting FileGDB). We also don't expose
# the CSV or GeoJSON drivers. Use Python's csv and json modules instead.
# Might still exclude a few more of these after making a pass through the
# entries for each at http://www.gdal.org/ogr/ogr_formats.html to screen
# out the multi-layer formats.

GMLAS does not appear on the list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.