1

I deleted SiteAddressPoint in the enterprise geodatabase. Now when I try to replace it I get an error that says it already exists. I have disconnected all connections and cleared locks. I have gone through all the REST services and stopped them and made sure "Lock schema" was unchecked. Here is what I have tried and the result:

Creating a new empty feature class. It will not let me proceed and says the name already exists.

Importing Feature class to feature class Fails and says the name already exists and It cannot find the feature class. Error 000258 Overwrite in geoprocessing is checked.

Python with arcpy.DisconnectUser(sde, 'ALL') and arcpy.ClearWorkspaceCache_management() I get ERROR 000601: Cannot delete xxx.DBO.SiteAddressPoint. May be locked by another application. Failed to execute (CopyFeatures).

I have tried in ArcMap 10.5.1, ArcCatalog, ArcGIS Pro 2.7 and the Python script both in ArcMap and in IDLE.

It is ArcGIS Server 10.5.1 and SQL Server.

How can I make a new SiteAddressPoint in the database?

1
  • 1
    Once a table is registered with the geodatabase, it should only be dropped using ArcObjects tools (ArcGIS UI, ArcPy, Using SQL fails to removed the entries in the metadata tables. The best way to correct he corrupted metadata is to use SQL to create a nominal table with the same name (CREATE TABLE foo (objectid integer NOT NULL)),then delete it with the UI (or ArcPy). – Vince Mar 10 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.