2

I'm having problem importing a point layer from Excel. I've saved the Excel file as a CSV and added it to QGIS (2.18) through 'Add delimited text layer' I've checked in semicolon and choosen the right coordinates.

That render a layer with correct attribute data - but no points. What am I doing wrong?

4
  • When I try zoom to layer - nothing happens... – Ola Hammarström Mar 12 at 9:43
  • 3
    Are you sure the separator is semicolon not comma? CSV is a comma separated values, so I think you need to use comma not semicolon. – ahmadhanb Mar 12 at 9:46
  • 1
    @ahmadhanb that is not not entirely true. A delimited file can be delimited by, for example, a semicolon or a tab character. You have the facility in the import to specify this - see File format -> custom delimiters. If you have successfully imported the data (as can be shown by an entry in the table of Contents and the ability to open the attribute file), then it sounds as if the geometry has not been picked up correctly. Check the definitions of "X" and "Y" on the input dialogue and also the CRS. – Leigh Bettenay Mar 12 at 10:29
  • 2
    If the CRS is different than the display CRS, make sure you have enabled On The Fly (OTF) reprojection, else geometries won't be shown. – JGH Mar 12 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.