0

I have a road network in production environment. Its an sde environment using Oracle database. We have a feature dataset in which network exist. This road network is using travel modes as well as evaluators.

We receive updates on road network like new features are added or some attributes get modified, to avoid layer getting locked as we have multiple user editing this so we have enabled versioning on road network.

When feature dataset is in versioned mode (No actual versions are created, this is for versioned editing purpose only) then road network cannot be built as it gives some error, so for that we always unregister as versioned, built the network and then register as versioned.

This approach is working fine for some time but today I was updating roads and now when following the usual process I am getting following errors when trying to built road network.

 ERROR 999999: Something unexpected caused the tool to fail. Contact Esri Technical Support (http://esriurl.com/support) to Report a Bug, and refer to the error help for potential solutions or workarounds.
 General function failure
 The logical network is of an older version and does not support the requested functionality.
 Failed to execute (BuildNetwork).

Now I am checking what caused this but failed to conclude a reason. I have checked for built errors and built file in temp folder

This is my built file log

Building Network: 0.0 seconds (0.0 total) - 0 MB memory   [12:05:31 PM]

Refine Cleaning Area: 0.0 seconds (0.0 total) - 0 MB memory   [12:05:31 PM]
Refine Cleaning Area Is Done, 4 Clusters (maxBoundingArea 200.00 km^2, relativeCoverage 10.00%), 4 Dirty Parts: 0.1 seconds (0.1 total) - 0 MB memory

Extract Geometry and Attribute Values: 0.0 seconds (0.1 total) - 4094 MB memory   [12:05:31 PM]
  Extracting RoadCentreline: 0.0 seconds (0.1 total) - 4094 MB memory   [12:05:31 PM]
         0 features: 0.1 seconds (0.2 total) - 4094 MB memory
  Extracted RoadCentreline, 10 features, 55 vertices: 0.2 seconds (0.4 total) - 4094 MB memory
  Extracting RoadCentreline: 0.0 seconds (0.4 total) - 4094 MB memory   [12:05:31 PM]
         0 features: 0.0 seconds (0.4 total) - 4094 MB memory
  Extracted RoadCentreline, 5 features, 21 vertices: 0.1 seconds (0.5 total) - 4094 MB memory
  Extracting RoadCentreline: 0.0 seconds (0.5 total) - 4094 MB memory   [12:05:31 PM]
         0 features: 0.0 seconds (0.5 total) - 4094 MB memory
  Extracted RoadCentreline, 6 features, 48 vertices: 0.1 seconds (0.6 total) - 4094 MB memory
  Extracting RoadCentreline: 0.0 seconds (0.6 total) - 4094 MB memory   [12:05:31 PM]
         0 features: 0.0 seconds (0.6 total) - 4094 MB memory
  Extracted RoadCentreline, 5 features, 10 vertices: 0.1 seconds (0.7 total) - 4094 MB memory
Extracting Geometry and Attribute Values Is Done: 0.0 seconds (0.7 total) - 4094 MB memory

Deleting Network Elements: 0.0 seconds (0.7 total) - 4094 MB memory   [12:05:31 PM]
  Deleted 26 edge elements: 0.0 seconds (0.7 total) - 4094 MB memory
  Deleted 15 junction elements: 0.4 seconds (1.0 total) - 4093 MB memory
Network Elements Deleted: 0.0 seconds (1.0 total) - 4093 MB memory

Matching connectivity: 0.0 seconds (1.0 total) - 8187 MB memory   [12:05:32 PM]
         0 vertices: 0.0 seconds (1.0 total) - 8187 MB memory
Matching connectivity done

  Node Count:                   134
  Nodes Thrown Out:              82
  System Junctions Created:      14

       0.0 seconds (1.1 total) - 8187 MB memory

Creating Junctions: 0.0 seconds (1.1 total) - 8187 MB memory   [12:05:32 PM]
Created 14 Junctions: 0.0 seconds (1.1 total) - 8187 MB memory

Defining Edges: 0.0 seconds (1.1 total) - 10235 MB memory   [12:05:32 PM]
Defined 26 Edges: 0.0 seconds (1.1 total) - 10235 MB memory

Creating Edges: 0.0 seconds (1.1 total) - 10235 MB memory   [12:05:32 PM]
Created 26 Edges: 0.1 seconds (1.2 total) - 10235 MB memory

Extracting Turns: 0.3 seconds (1.5 total) - 10235 MB memory   [12:05:32 PM]
Turns Extracted:  0.0 seconds (1.5 total) - 10235 MB memory


Network Built: 0.0 seconds (1.5 total) - 10235 MB memory   [12:05:32 PM]

I am not sure why i am getting this error.

Note: We just updated Portal to 10.8 but I am not sure if it has anything to do with Portal as ArcGIS Pro is the same version 2.5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.