I am trying to export mapping and boundary data from QGIS into AutoCAD to use for concept drawings in South Australia. At my previous company, I would just set up the projection as WGS84, then set the project CRS to MGA Zone 53 or 54, and it would all look perfect, and it would export easily.

When I try to do that now, the maps either look utterly bizarre, or they are in totally the wrong coordinates (not just 'off' by a bit).

I would always tick the 'On The Fly' option in previous versions (using V3.10 now), and in fact I temporarily rolled back to version 2.18 purely to tick that box, but the result was the same.

I should be seeing coordinates around E:280,000 - N:6,120,000. Currently the best I can get them is to E:55,500,000 - N:-4,100,000, which is clearly wrong.

Is anyone able to shed some light on how to fix this, and to tell me how badly I understand projections?

1 Answer 1


Couple of things to check

  • Make sure your project coordinate system is set to MGA (File > Project Properties > CRS
  • Make sure your datasets are actually in the coordinate system that you have set them to.

The other thing to check is that by default, QGIS has a few different versions of WGS84 in its list. Check you that you are using the ESPG: 4326 version

Your problem is not uncommon - usually, if im bringing in a datasource that says its MGA Zone 50 (im in Perth) - and I set it to that - but it ends up elsewhere, it usually means that the source data is NOT MGA50. So try playing around with the source dataset coord system. that is where i would bet your problem is.

  • 1
    Thanks for the reply, that worked. I thought I had tried everything at least a million times in slightly different configurations each time, yet I brought in a basic Bing maps image, set it to 7854 (GDA2020), and it just settled into the correct position immediately. I feel like this is the equivalent of toiling over something for hours and hours, and the second you ask a question, it just works properly. Cheers!
    – Phil
    Mar 17, 2021 at 6:01
  • Is that WGS84 north or south? It could be that you're setting your CRS as WGS84/UTM Zone 54 north (EPSG:32654) instead of WGS84/UTM Zone 54 south (EPSG:32754) which would be about right for a very negative northing with a reasonable easting. What does the data look like natively (without project-on-the-fly?) are the coordinates reasonable there? It could also be that your data has a local datum (site datum). Mar 17, 2021 at 6:29
  • I had tried all of the WGS84 projections available, and a bunch of others - including the one nr_aus suggested, and in each of those, I had tried all of the zone54s I could (in addition to others). I was having the issue with data like google maps, which I know works properly. For some reason, the only thing that I think actually changed it was accessing the CRS panel via the menu (as suggested by nr_aus) rather than via the bottom-right corner button. To me they bring up the same window, but maybe they are slightly different? Anyway, it works now, which is the main thing. Cheers.
    – Phil
    Mar 18, 2021 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.