I'm having issues exporting a georeferenced map from QGIS using version 3.16.0-Hannover. I'm getting a "could not create print device" error (more information below).

What I'm trying to do:

I'm trying to export a limited view (approximately 50x50km) of a larger data set (vector data of the whole of Sweden) to a georeferenced PDF in order to view it in map software like "Avenza maps" etc.

My issue is the following:

Using QGIS 3.16 I get an error upon trying to export a geopdf from QGIS layout manager. The error reads "could not create print device".

Link to image of error: https://i.stack.imgur.com/TcSV9.png

The export settings I use are the defaults.

Link to image of export settings: https://i.stack.imgur.com/u0e2I.png

Example project:

Here's a link to an example project giving me the error (new projects with the same dataset and layout get the same error).

Project link: https://mega.nz/file/S1x0FAYL#SuRhQjFUY_tbyO3iJrLiPsKlEO7G6H4VZ_-_kmwK5nc

Here's what I know/ think so far:

  1. I've tried to google the issue but the results provided there has not been helpful for me.
  2. Exporting a geopdf directly from map view gives me a similary error ("could not save the map to pdf")
  3. Saving a non georeferenced pdf from the same project/ layout and using the same dataset works fine.

What could be the issue?

  • Please accept the answer/comments with images.
    – Mapperz
    Mar 24, 2021 at 15:49
  • Please click the green accept check mark ✅ next to @Mapperz’s answer when you are able to. In the meantime I’ll edit out anything that should not be in the area reserved for your question.
    – PolyGeo
    Mar 25, 2021 at 2:26
  • Exporting the complex vector layer (stream network lines in my case) into a gpkg format fixed the issue for me.
    – Philipp R
    Jun 18, 2021 at 11:04

4 Answers 4


More of a troubleshooting comment. QGIS 3.18.1 used here to export to geopdf.

No errors or issue exporting this.

but the check in Adobe Illustrator (v25.2.1) shows the Polygon layer 'Markdata riks' is missing or not getting exported.

This might be due to a couple of reasons.

  1. Too many vertices in the polygon (you need to generalise the data before export)
  2. polygon geometry [fid 109137] issue *see screenshot

enter image description here

I found this polygon has a 'Ring self-intersection' that needs to be fixed. (This was done using the check validity Vector>Geometry Tools>Check Validity)

enter image description here

Nice map though, sharing the project helped looking into issue. hence this comment/reply. hope it helps.

  • 1
    Thank you! This fixed my issue! Again thanks a bunch, it was driving me crazy.
    – Moose
    Mar 24, 2021 at 15:29

Sometimes it helps to turn off the option INCLUDE GEO REFERECNE I find another method: Turn on layers option: rasterized


The error "could not create print device" can arise simply because of trying to overwrite an existing pdf file when that file is open (thus locked). See here. With that in mind I guess this could also mean that it's an error message shown more broadly just to mean 'I can't do that for some unspecified reason'. (Hoping this gets fixed - it caused me a headache today until I found that post.)


Unchecking “Include vector feature information” worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.