I have one very interesting issue which I do not know how to solve/understand. In FME I used the LineOnAreaOverlayer transformer to get new intersected lines, these some are inside and outside polygons. When I visualize it with FMEViewer and visualize them with ArcMAP I get different results.

In ArcMAP it is visible like line was not intersected according to the polygon, but at the same time in FMEViewer everything is fine. help please!

This is situation within FMEViever

And this is within ArcMAP

Both representing same line and area.

And I tried to do intersection within ArcMap and intersections occures at the same place as with FME:

intersected with ArcMap

  • 3
    Screenshots might be helpful. Nov 2 '12 at 13:12
  • What format are you viewing the fme export in ArcMap as shapefile?
    – Mapperz
    Nov 2 '12 at 13:20
  • Filegeodatabase as a format. So after running FME workspace I get one polyline fc class which polylines should be splitted over polygons. I am wondering if LineOnAreaOverlayer does its job 100% correct?!
    – Z77
    Nov 2 '12 at 13:36
  • I have to find the way how to insert images here
    – Z77
    Nov 6 '12 at 6:55
  • 1
    When editing the question press Ctrl+G or click on the picture icon on the top bar to open the add picture dialogue. Or if you are having problems with that, paste in the image hyperlinks and someone will inline them for you.
    – sgrieve
    Nov 6 '12 at 10:06

Are you writing the data to Geodatabase and then viewing that in the FME Viewer, or are you sending the data directly to the FME Viewer from the workspace? Really these are two different things.

For example, if you see the results correctly when sending the data directly, but it looks like ArcGIS when you open the Geodatabase to view it, then the issue is obviously in writing out the data (and the overlayer is correct).

If the two look the same (and are correct) when viewing in FME Viewer, then I would look to ArcGIS for the issue.

To be honest, my best guess is that the resolution isn't fine enough to record the point exactly at that location, and it's shifted/snapped to the nearest grid position during writing.

  • Yes. It looks like this was problem, although spatial resultion was the same for to datasets (checked in ArcMap) but datasets came from different sources. So I fixed it with creating/validating topology. And that was partial soultion. Next I did, is changing manually geometry of critical objects. But what will be the most professional solution, I do not know. My apologize I forgot to answer here (too busy).
    – Z77
    Nov 28 '12 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.