1

I am having an issue exporting a georeferenced PDF using QGIS version 3.16.5. So far the google search to fix the problem has not been successful. Using on Windows 10 64 bit. I have a limited knowledge of how QGIS functions (and coding in general), but up until receiving my new computer last week was able to use the georeferenced PDF export function with no issues.

I am trying to export a limited view (3 km by 4 km max) of a map that contains the Bing basemap, a orthophoto.ecw, and one shapefile. I keep getting a 'could not create print device' when trying to export a Georeferenced PDF.

I started with version 3.18, so I uninstalled and reinstalled 3.16. I made sure that all of the updates required on my computer were up to date. I have tried exporting on a different computer using 3.16. I am using the same mapfile (project) and map layout template, basemap, orthophoto, and shapefile as a co-worker who has no issues exporting georeferenced PDFs.

View of Export Options Advanced Options Layers Error message Map extent with Bing basemap, orthophoto, and bird survey layer displayed

2
  • Do all your layers have the same CRS? what happens when you export to a non-geoPDF?
    – Mapperz
    Commented Apr 1, 2021 at 1:49
  • No, the layers do not all have the same CRS. The survey layer (red) has EPSG:26909, orthophoto has EPSG:26909, and the Bing satellite is EPSG:3857. When I change the bing satellite to 26909 it takes me to another part of the world. I have changed the setting so much that when I export even a non-geo PDF I get a blank empty map with just a legend and layout features.. Commented Apr 1, 2021 at 23:49

1 Answer 1

0

I have been exporting using Qgis 3.18.

The initial PDF export failed, so I turned off the aerial image (which was an ecw) . then the pdf export worked. When i tried again with the ECW on, it also worked. Also I just verified exporting with OSM as a basemap, which worked also. Two of the vector layers have different coord systems.

I also discovered this related article -https://gis.stackexchange.com/questions/390835/qgis-3-16-could-not-create-print-device-error-geopdf

which suggests that the problem exists in the source data having errors. I would suggest that you try printing without certain layers turned on, see which ones cause the error when turned on and investigate for errors - see linked article for more info on their particular problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.