The setting: I encountered a very strange behaviour using QGIS on Win 10, standalone installer. It both happens with 3.16 and 3.18 (I also tested with older, still installed versions like 3.4: same problem).

The problem: I was able to work normally with both QGIS versions in the last days and weeks. But today, suddenly, I was not able any more to change layer styling - see screenshot at the bottom. Whatever I tried, no way to set another style, QGIS always sticks to the styles attributed by default when creating new layers or by the one defined in the project when opening existing projects. Assigning one of the pre-defined styles does not work either. The preview in the layer styling panel however works correctly.

What I tried:

  • I restarted QGIS several times and my computer as well. When I finally had a look to the QGIS version installed, I remarked that it was QGIS 3.18.0 instead of 3.18.1. I had installed 3.18.1 before, but for some mysterious reason it seems to have gone. The same, by the way, with 3.16.5 - it's gone, when I start 3.16, the pointrelease 3.16.3 (the last I installed before 3.16.5) opens. In both versions, I'm not able to change styles.

  • I re-installed QGIS 3.18.1, the newst standalone release, downloaded directly from https://www.qgis.org. However, when I start the newly installed version, the problem persists. Screenshot: Installation folder with the newly installed 3.18.1 version - you can see as creation date today's datum: enter image description here

The context: The problem happened after QGIS crashed on the Processing plugin was deactivated. I re-activated it. Don't know if that has some connection to the problem.

The Question: Does anyone have an idea what happened and how to solve the problem?

Screenshot: opening an empty project, adding a temporary polygon layer in EPSG:3857, drawing a single polygon with valid extent. As you can see on the right in the layer styling panel, changing the style does not affect how the polygon is rendered. Adding additional symbol layers also does not change anything. Same for lines and points: enter image description here

  • Did you try a clean new profile? Make a backup of your current one before.
    – MrXsquared
    Commented Apr 4, 2021 at 16:32
  • Indeed, changing to another user profile helped. Any idea what went wrong - and how possibly "repair" my old profile?
    – Babel
    Commented Apr 4, 2021 at 16:43
  • 3
    You can try to copy the step-by-step files from the new profile to the old profile: starting with symbology-style.db (in C:\Users\usernameAppData\Roaming\QGIS\QGIS3\profiles\profile-name), qgis.ini (in C:\Users\usernameAppData\Roaming\QGIS\QGIS3\profiles\profile-name\QGIS). You can also have a look to processing and python folder in your old profile an delete the content in there. Be careful and make a backup of your profile folder before...
    – eurojam
    Commented Apr 5, 2021 at 8:34
  • Thanks @eurojam for this idea - this is indeed a good way to re-create user profiles. I'm happy to have solved my problem, but having a closer look to these user profile settings is a good idea anyway.
    – Babel
    Commented Apr 5, 2021 at 9:57

1 Answer 1


Sometimes, it takes a night's sleep and a fresh view to see the obvious. The problem was that the checkbox Live update at the bottom of the layer panel was deactivated (as can be seen on the screenshot of the question). I can't remember how that happened, I did not do that manually (at least not intentionally). Quite embarrassing to have overlooked someting as simple as this, but I hope this answer might help others with a similar problem.

Using a clean new user profile as proposed by @MrXsquared is great as a workaround in such situations, as you can continue working. Would be worth to create a copy of my current user profile to fall back to it in case of any other problem. The step-by-step proposal by @eurojam to re-create a user profile is another great possibility to consider in such situations.

Screenshot: checking the box Live update solved the problem:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.