4

I am trying to create a raster data set from county level polygon data for the US. I have successfully created one raster from a dataset, but when attempting another, it does not work. I am wondering if I am missing something. It's in ArcMap 10, I have tried moving the cell size up to 100 (it took the recommended cell size for the other data set) and have also changed any NULL values to zero. I get the "999999 : Error executing function". I have also tried the Feature to Raster tool. Same error message. Any ideas or troubleshooting tips would be great! Thanks.

  • 2
    Is there any additional error information in Geoprocessing > Results? – Aaron Nov 5 '12 at 19:18
  • Try to check your polygon data, maybe there are some bad polygons (zero area, or self-intersecting, or something else wrong) – nadya Nov 5 '12 at 19:20
  • 4
    ArcMap 10 sometimes has issues with background processing on certain machines. If you have background processing enabled, try disabling it (Geoprocessing -> Geoprocessing Options -> Uncheck Enable under Background Processing). Try running your process again and see if that works. – bluefoot Nov 5 '12 at 19:22
  • 2
    Paths with spaces are an issue. Try saving the output to simple folder and keep the output filename under 10 characters in length. – user681 Nov 5 '12 at 19:45
  • 1
    Thanks everyone. The first thing I tried was disabling the background processing and it worked! – Anna Nov 5 '12 at 20:01
5

Adding my comment as an answer since this seems to be a solution:

ArcMap 10 sometimes has issues with background processing on certain machines. If you have background processing enabled, try disabling it (Geoprocessing -> Geoprocessing Options -> Uncheck Enable under Background Processing). Try running your process again and see if that works.

  • This solution also worked for me when I had a similar problem. – Gideon Sep 25 '13 at 9:37
3

I see that the question and answers are quite old, but still will post my answer as it could help someone in the future. I get this error mostly because invalid characters in the paths and file names. Keep your whole path strictly in ASCII without spaces and the filename under 13 characters.

1

Althoug I have unchecked the background processing option, the issue wasn't resolved. I found out that saving the polygon in the default.gdb (Documents /arcGis/default.gdb), instead of somewhere on the network, it's problem is solved.

0

I recently had this problem. I used another raster to set the environment settings (extent, snap raster, and cell size). The raster was not in the same projection as my shapefile. When I re-projected my shapefile to the same projection as the raster layer, the tool was successful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.