2

I have a shapefile of conifer trees in QGIS 3.16 that I exported as dxf and opened in Global Mapper. In QGIS, the area covered by conifers is easily recongnizable with the blue color as in IMG1. enter image description here In dxf format, only the lines around the areas are visible, so it is not possibile to distinguish easily whether the tree polygons are inside or outside of these lines as in IMG2. enter image description here The issue is that when I select an item in the dxf file, it selects all the area of that polygon and not only the separate blue areas as in IMG3. As shown, the white areas inside the big blue polygon are also selected in dxf, while they are no conifers there. enter image description here Is there a way to visualize the polygons in dxf format as they are in GIS? Can I change something in my polygon so it appears the same as I see it in GIS for my boss who sees it in CAD?

4
  • Yeah, teach you boss how to look at stuff in GIS, or give him a PDF.
    – Erik
    Apr 13, 2021 at 12:14
  • Thanks @Erik, I will tell him that :D
    – Paris
    Apr 13, 2021 at 13:20
  • Alternatively you could convert you data to raster and load the raster into CAD.
    – Erik
    Apr 13, 2021 at 13:27
  • 1
    AutoCAD uses Hatch first the polylines need to be closed knowledge.autodesk.com/support/autocad-map-3d/learn-explore/…
    – Mapperz
    Apr 13, 2021 at 15:28

2 Answers 2

2

When converting to .DXF, QGIS polygon features are converted into CAD hatch features, and QGIS line features are converted into CAD polyline features. Points are a little more complicated to explain, as it can depend on the symbology used to display the points in QGIS.

It is important to pay attention to the [Symbology mode] setting in the QGIS [DXF Export] dialog. There are 3 choices available:

  • No symbology
  • Feature symbology
  • Symbol Layer symbology

You should likely use [Feature symbology] (try this 1st) or [Symbol Layer symbology] (try this 2nd).

There are multiple dialogs to export .DWG files from QGIS, and regarless of which one(s) you used, it is possible that you had the [Symbology mode] set differently.

enter image description here

1
  • Thanks @GSC_Mapper, this is a better solution. Both of the symbology options worked well.
    – Paris
    Apr 28, 2021 at 8:17
2

I solved it by simply using select features in QGIS and selecting all features and exporting the selected features into dxf file. This way when I opened it in Global Mapper, it selected the polygon as it was in QGIS. enter image description here I do not know why this works but it solved my issue for now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.